CVE-2026-93857
CVE-2026-93857 · Fireware OS Pre-Authentication Stack Buffer Overflow in SIP Proxy Allows Remote Code Execution
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A stack-based buffer overflow vulnerability in Fireware OS's SIP proxy allows a remote, unauthenticated attacker to execute arbitrary code by sending a specially crafted request through a policy that uses the SIP proxy.
CVSS 9.2 · Critical · EPSS 0.5% · Public exploit · Fix available
- Published
- Updated
Affected products and versions
fireware os
- Versions
- ≥ 2025.1, < 2026.4: Affected (custom)
- ≥ 12.0, < 12.12.4: Affected (custom)
Update to 12.12.4; Update to 2026.4
fireware os
- Versions
- ≥ 12.0, < 12.5.22: Affected (custom)
Update to 12.5.22