CVE-2026-94286
CVE-2026-94286 · Out-of-bounds read in libXtst's RECORD reply parser
This page contains facts from public vulnerability sources. Check the original advisory before updating.
An out-of-bounds read in libXtst's RECORD reply parser in libXtst before 1.2.6 could be used by malicious X servers to crash attached X clients.
CVSS 7.1 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
libxtst
- Versions
- ≥ 0, < 1.2.6: Affected (rpm)
Update to 1.2.6
libxtst Debian:12
- Versions
- 2:1.2.3-1.1
- 2:1.2.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxtst Debian:13
- Versions
- 2:1.2.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxtst Debian:14
- Versions
- 2:1.2.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libxtst Ubuntu:Pro:16.04:LTS
- Versions
- 2:1.2.2-1
- Affected ranges
- ECOSYSTEM: < 2:1.2.2-1ubuntu0.1~esm1
Update to 2:1.2.2-1ubuntu0.1~esm1
libxtst Ubuntu:Pro:18.04:LTS
- Versions
- 2:1.2.3-1
- Affected ranges
- ECOSYSTEM: < 2:1.2.3-1ubuntu0.18.04.1~esm1
Update to 2:1.2.3-1ubuntu0.18.04.1~esm1
libxtst Ubuntu:Pro:20.04:LTS
- Versions
- 2:1.2.3-1
- Affected ranges
- ECOSYSTEM: < 2:1.2.3-1ubuntu0.20.04.1~esm1
Update to 2:1.2.3-1ubuntu0.20.04.1~esm1
libxtst Ubuntu:22.04:LTS
- Versions
- 2:1.2.3-1build2
- 2:1.2.3-1build3
- 2:1.2.3-1build4
- Affected ranges
- ECOSYSTEM: < 2:1.2.3-1ubuntu0.22.04.1
Update to 2:1.2.3-1ubuntu0.22.04.1
libxtst Ubuntu:24.04:LTS
- Versions
- 2:1.2.3-1.1
- 2:1.2.3-1.1build1
- Affected ranges
- ECOSYSTEM: < 2:1.2.3-1.1ubuntu0.1
Update to 2:1.2.3-1.1ubuntu0.1
libxtst Ubuntu:26.10
- Versions
- 2:1.2.5-1build1
- Affected ranges
- ECOSYSTEM: < 2:1.2.5-1ubuntu1
Update to 2:1.2.5-1ubuntu1
libxtst Ubuntu:26.04:LTS
- Versions
- 2:1.2.5-1
- 2:1.2.5-1build1
- Affected ranges
- ECOSYSTEM: < 2:1.2.5-1ubuntu0.1
Update to 2:1.2.5-1ubuntu0.1