p PatchFirst

CVE-2026-9495

CVE-2026-9495

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Versions of the package @koa/router from 14.0.0 and before 15.0.0 are vulnerable to Access Control Bypass due to the middleware being silently dropped from the execution chain when the router prefix contains path parameters. Depending on what the skipped middleware was supposed to protect, an attacker could bypass authentication and authorization, evade rate limiting or bypass input sanitization.

CVSS 6.9 · Medium · EPSS 0.4% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • @koa/router

    Versions
    • ≥ 14.0.0, < 15.0.0: Affected (semver)

    Update to 15.0.0

  • @koa/router npm

    Affected ranges
    • SEMVER: ≥ 14.0.0, < 15.0.0

    Update to 15.0.0

Original sources

Check your server →