CVE-2026-9673
CVE-2026-9673
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Versions of the package json-2-csv from 3.15.0 and before 5.5.11 are vulnerable to CSV Injection via the preventCsvInjection option which can be bypassed. An attacker can inject formulas into CSV files, which execute when the files are opened in spreadsheet applications.
CVSS 7.0 · High · EPSS 0.2% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
json-2-csv
- Versions
- ≥ 3.15.0, < 5.5.11: Affected (semver)
Update to 5.5.11
org.webjars.npm:json-2-csv
- Versions
- ≥ 0: Affected (semver)
No fix published
json-2-csv npm
- Affected ranges
- SEMVER: ≥ 3.15.0, < 5.5.11
Update to 5.5.11
Original sources
- https://security.snyk.io/vuln/SNYK-JS-JSON2CSV-14221326
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-17115116
- https://github.com/mrodrig/json-2-csv/blob/main/src/json2csv.ts%23L410
- https://gist.github.com/whoamins/299745a2d36b482b44e9613b78e40613
- https://github.com/mrodrig/json-2-csv/commit/0fdd0bb6d0273178cd940afc323ccbce19688229
- https://nvd.nist.gov/vuln/detail/CVE-2026-9673