CVE-2026-9698
CVE-2026-9698 · DBI versions before 1.648 for Perl saved errors in a limited-sized buffer
This page contains facts from public vulnerability sources. Check the original advisory before updating.
DBI versions before 1.648 for Perl saved errors in a limited-sized buffer. Error messages that were returned when RaiseError, PrintError or HandleError were set were written to a 200-byte buffer without a length limit. Attackers that can influence the error text in an application can trigger a buffer overflow.
CVSS 7.5 · High · EPSS 0.5% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
dbi
- Versions
- ≥ 0, < 1.648: Affected (custom)
Update to 1.648
libdbi-perl Debian:12
- Versions
- 1.643-4
- Affected ranges
- ECOSYSTEM: < 1.643-4+deb12u1
Update to 1.643-4+deb12u1
libdbi-perl Debian:13
- Versions
- 1.647-1
- Affected ranges
- ECOSYSTEM: < 1.647-1+deb13u1
Update to 1.647-1+deb13u1
libdbi-perl Debian:14
- Versions
- 1.647-1
- Affected ranges
- ECOSYSTEM: < 1.648-1
Update to 1.648-1
libdbi-perl Ubuntu:Pro:14.04:LTS
- Versions
- 1.627-1
- 1.628-1
- 1.630-1
- 1.630-1ubuntu0.1~esm1
- 1.630-1ubuntu0.1~esm4
- 1.630-1ubuntu0.1~esm5
- Affected ranges
- ECOSYSTEM: < 1.630-1ubuntu0.1~esm6
Update to 1.630-1ubuntu0.1~esm6
libdbi-perl Ubuntu:Pro:16.04:LTS
- Versions
- 1.633-1
- 1.634-1
- 1.634-1build1
- 1.634-1ubuntu0.1
- 1.634-1ubuntu0.2
- 1.634-1ubuntu0.2+esm1
- Affected ranges
- ECOSYSTEM: < 1.634-1ubuntu0.2+esm2
Update to 1.634-1ubuntu0.2+esm2
libdbi-perl Ubuntu:Pro:18.04:LTS
- Versions
- 1.637-1
- 1.639-1
- 1.640-1
- 1.640-1ubuntu0.1
- 1.640-1ubuntu0.2
- 1.640-1ubuntu0.3
- Affected ranges
- ECOSYSTEM: < 1.640-1ubuntu0.3+esm1
Update to 1.640-1ubuntu0.3+esm1
libdbi-perl Ubuntu:Pro:20.04:LTS
- Versions
- 1.642-1
- 1.642-1build1
- 1.643-1
- 1.643-1ubuntu0.1
- Affected ranges
- ECOSYSTEM: < 1.643-1ubuntu0.1+esm1
Update to 1.643-1ubuntu0.1+esm1
libdbi-perl Ubuntu:22.04:LTS
- Versions
- 1.643-3build2
- 1.643-3build3
- Affected ranges
- ECOSYSTEM: < 1.643-3ubuntu0.1
Update to 1.643-3ubuntu0.1
libdbi-perl Ubuntu:24.04:LTS
- Versions
- 1.643-4
- 1.643-4build1
- 1.643-4build2
- 1.643-4build3
- Affected ranges
- ECOSYSTEM: < 1.643-4ubuntu0.1
Update to 1.643-4ubuntu0.1
libdbi-perl Ubuntu:25.10
- Versions
- 1.647-1
- Affected ranges
- ECOSYSTEM: < 1.647-1ubuntu0.25.10.1
Update to 1.647-1ubuntu0.25.10.1
libdbi-perl Ubuntu:26.04:LTS
- Versions
- 1.647-1
- 1.647-1build1
- Affected ranges
- ECOSYSTEM: < 1.647-1ubuntu0.26.04.1
Update to 1.647-1ubuntu0.26.04.1
Original sources
- https://metacpan.org/release/HMBRAND/DBI-1.648/changes
- https://github.com/perl5-dbi/dbi/commit/bfe5d73c162d2d1f761a639a0aa33aad6a9eb54e.patch
- http://www.openwall.com/lists/oss-security/2026/06/09/9
- https://access.redhat.com/security/cve/CVE-2026-9698
- https://bugzilla.redhat.com/show_bug.cgi?id=2486734
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-9698.json
- https://access.redhat.com/errata/RHSA-2026:38513
- https://access.redhat.com/errata/RHSA-2026:38901
- https://access.redhat.com/errata/RHSA-2026:38512
- https://access.redhat.com/errata/RHSA-2026:62667
- https://access.redhat.com/errata/RHSA-2026:53371
- https://nvd.nist.gov/vuln/detail/CVE-2026-9698