CVE-2026-97229
CVE-2026-97229 · Integer Overflow or Wraparound in GitLab
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an unauthenticated user to execute arbitrary code on the GitLab server via a specially crafted regular expression in a CI/CD configuration, due to insufficient regular expression validation.
CVSS 10.0 · Critical · EPSS 18.4% · Public exploit · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gitlab
- Versions
- ≥ 19.2, < 19.2.8: Affected (semver)
- ≥ 19.3, < 19.3.5: Affected (semver)
- ≥ 19.4, < 19.4.2: Affected (semver)
Update to 19.2.8; Update to 19.3.5; Update to 19.4.2
ruby3.1 Debian:12
- Versions
- 3.1.2-7
- 3.1.2-7+deb12u1
- 3.1.2-7+hurd.1
- 3.1.2-8
- 3.1.2-8.1~exp1
- 3.1.2-8.3
- 3.1.2-8.4
- 3.1.2-8.5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby3.3 Debian:13
- Versions
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ruby3.3 Debian:14
- Versions
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gitlab Ubuntu:16.04:LTS
- Versions
- 8.4.3+dfsg-9
- 8.4.3+dfsg-12
- 8.5.8+dfsg-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published