CVE-2026-9742
CVE-2026-9742 · Authenticate command with specific mechanism parameter can trigger server crash
This page contains facts from public vulnerability sources. Check the original advisory before updating.
When OIDC authentication is enabled in configuration, clients may set specific values in the "mechanism" parameter of the "authenticate" command that lead to server crash. The authenticate command is accessible to unauthenticated clients, leading to pre-auth denial-of-service in affected product configurations.
CVSS 8.2 · High · EPSS 0.3% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
mongodb server
- Versions
- ≥ 8.3.0, < 8.3.3: Affected (custom)
- ≥ 8.2.0, < 8.2.10: Affected (custom)
Update to 8.2.10; Update to 8.3.3
mongodb Ubuntu:Pro:14.04:LTS
- Versions
- 1:2.4.6-0ubuntu5
- 1:2.4.6-0ubuntu6
- 1:2.4.8-1ubuntu1
- 1:2.4.8-2
- 1:2.4.9-1
- 1:2.4.9-1ubuntu1
- 1:2.4.9-1ubuntu2
- 1:2.4.9-1ubuntu2+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:16.04:LTS
- Versions
- 1:2.6.10-0ubuntu1
- 1:2.6.10-0ubuntu1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:18.04:LTS
- Versions
- 1:3.4.7-1
- 1:3.4.7-1ubuntu1
- 1:3.4.7-1ubuntu2
- 1:3.4.7-1ubuntu4
- 1:3.4.14-3ubuntu1
- 1:3.4.14-3ubuntu2
- 1:3.6.3-0ubuntu1
- 1:3.6.3-0ubuntu1.1
- 1:3.6.3-0ubuntu1.3
- 1:3.6.3-0ubuntu1.4
- 1:3.6.3-0ubuntu1.4+esm1
- 1:3.6.3-0ubuntu1.4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
mongodb Ubuntu:Pro:20.04:LTS
- Versions
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.2
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3
- 1:3.6.9+really3.6.8+90~g8e540c0b6d-0ubuntu5.3+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published