p PatchFirst

PatchFirst · Latest vulnerabilities

postgresql-13 vulnerabilities · Page 2

Vulnerabilities published for postgresql-13 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 26

  1. CVE-2021-32027

    High · CVSS 8.8EPSS 1.99%Fix available

    CVE-2021-32027

    A flaw was found in postgresql in versions before 13.3, before 12.7, before 11.12, before 10.17 and before 9.6.22. While modifying certain SQL array values, missing bounds checks let authenticated database users write arbitrary bytes to a wide area of server memory. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 13.3-1
    Published Updated
  2. CVE-2021-3393

    Medium · CVSS 4.3EPSS 1.19%Fix available

    CVE-2021-3393

    An information leak was discovered in postgresql in versions before 13.2, before 12.6 and before 11.11. A user having UPDATE permission but not SELECT permission to a particular column could craft queries which, under some circumstances, might disclose values from that column in error messages. An attacker could use this flaw to obtain information stored in a column they are allowed to write but not read.

    • Update to 13.2-1
    Published Updated
  3. CVE-2020-25696

    High · CVSS 7.5EPSS 2.7%Fix available

    CVE-2020-25696

    A flaw was found in the psql interactive terminal of PostgreSQL in versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If an interactive psql session uses \gset when querying a compromised server, the attacker can execute arbitrary code as the operating system account running psql. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 13.1-1
    Published Updated
  4. CVE-2020-25695

    High · CVSS 8.8EPSS 46.44%Fix available

    CVE-2020-25695

    A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. An attacker having permission to create non-temporary objects in at least one schema can execute arbitrary SQL functions under the identity of a superuser. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 13.1-1
    Published Updated
  5. CVE-2020-25694

    High · CVSS 8.1EPSS 1.59%Fix available

    CVE-2020-25694

    A flaw was found in PostgreSQL versions before 13.1, before 12.5, before 11.10, before 10.15, before 9.6.20 and before 9.5.24. If a client application that creates additional database connections only reuses the basic connection parameters while dropping security-relevant parameters, an opportunity for a man-in-the-middle attack, or the ability to observe clear-text transmissions, could exist. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.

    • Update to 13.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →