p PatchFirst

PatchFirst · Latest vulnerabilities

dokuwiki vulnerabilities · Page 2

Vulnerabilities published for dokuwiki in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 37

  1. CVE-2012-2128

    Not ratedEPSS 1.24%Fix available

    CVE-2012-2128

    Cross-site request forgery (CSRF) vulnerability in doku.php in DokuWiki 2012-01-25 Angua allows remote attackers to hijack the authentication of administrators for requests that add arbitrary users. NOTE: this issue has been disputed by the vendor, who states that it is resultant from CVE-2012-2129: "the exploit code simply uses the XSS hole to extract a valid CSRF token."

    • Update to 0.0.20120125a-1
    Published Updated
  2. CVE-2010-0289

    Not ratedEPSS 1.76%Fix available

    CVE-2010-0289

    Multiple cross-site request forgery (CSRF) vulnerabilities in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25c allow remote attackers to hijack the authentication of administrators for requests that modify access control rules, and other unspecified requests, via unknown vectors.

    • Update to 0.0.20090214b-3.1
    Published Updated
  3. CVE-2010-0288

    Not ratedEPSS 10.75%Public exploitFix available

    CVE-2010-0288

    A typo in the administrator permission check in the ACL Manager plugin (plugins/acl/ajax.php) in DokuWiki before 2009-12-25b allows remote attackers to gain privileges and access closed wikis by editing current ACL statements, as demonstrated in the wild in January 2010.

    • Update to 0.0.20090214b-3.1
    Published Updated
  4. CVE-2009-1960

    Not ratedEPSS 23.16%Public exploitFix available

    CVE-2009-1960

    inc/init.php in DokuWiki 2009-02-14, rc2009-02-06, and rc2009-01-30, when register_globals is enabled, allows remote attackers to include and execute arbitrary local files via the config_cascade[main][default][] parameter to doku.php. NOTE: PHP remote file inclusion is also possible in PHP 5 using ftp:// URLs.

    • Update to 0.0.20090214b-1
    Published Updated
  5. CVE-2008-5186

    Not ratedEPSS 1.97%Fix available

    CVE-2008-5186

    The set_language_path function in geshi.php in Generic Syntax Highlighter (GeSHi) before 1.0.8.1 might allow remote attackers to conduct file inclusion attacks via crafted inputs that influence the default language path ($path variable). NOTE: this issue has been disputed by a vendor, stating that only a static value is used, so this is not a vulnerability in GeSHi. Separate CVE identifiers would be created for web applications that integrate GeSHi in a way that allows control of the default language path

    • Update to 0.0.20080505-3.1
    Published Updated
  6. CVE-2006-6965

    Not ratedEPSS 1.37%Fix available

    CVE-2006-6965

    CRLF injection vulnerability in lib/exe/fetch.php in DokuWiki 2006-03-09e, and possibly earlier, allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via CRLF sequences in the media parameter. NOTE: this issue can be leveraged for XSS attacks.

    • Update to 0.0.20061106-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →