p PatchFirst

PatchFirst · Latest vulnerabilities

ghostscript vulnerabilities · Page 9

Vulnerabilities published for ghostscript in the last 30 days: 2. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 170

  1. CVE-2009-0196

    Not ratedEPSS 7.43%Fix available

    CVE-2009-0196

    Heap-based buffer overflow in the big2_decode_symbol_dict function (jbig2_symbol_dict.c) in the JBIG2 decoding library (jbig2dec) in Ghostscript 8.64, and probably earlier versions, allows remote attackers to execute arbitrary code via a PDF file with a JBIG2 symbol dictionary segment with a large run length value.

    • Update to 8.64~dfsg-1.1
    Published Updated
  2. CVE-2009-0792

    Not ratedEPSS 3.99%Fix available

    CVE-2009-0792

    Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images. NOTE: this issue exists because of an incomplete fix for CVE-2009-0583.

    • Update to 8.64~dfsg-1.1
    Published Updated
  3. CVE-2009-0584

    Not ratedEPSS 4.07%Fix available

    CVE-2009-0584

    icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code by using a device file for processing a crafted image file associated with large integer values for certain sizes, related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

    • Update to 8.64~dfsg-1.1
    Published Updated
  4. CVE-2009-0583

    Not ratedEPSS 4.75%Fix available

    CVE-2009-0583

    Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

    • Update to 8.64~dfsg-1.1
    Published Updated
  5. CVE-2007-2721

    Not ratedEPSS 2.27%Fix available

    CVE-2007-2721

    The jpc_qcx_getcompparms function in jpc/jpc_cs.c for the JasPer JPEG-2000 library (libjasper) before 1.900 allows remote user-assisted attackers to cause a denial of service (crash) and possibly corrupt the heap via malformed image files, as originally demonstrated using imagemagick convert.

    • Update to 8.61.dfsg.1~svn8187-1.1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →