p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 3

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 283

  1. CVE-2025-61640

    Low · CVSS 0EPSS 0.25%Fix available

    Stored XSS through system messages in Special:RecentChangesLinked (MW Core)

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Rcfilters/ui/RclToOrFromWidget.Js. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.

    • Update to 1:1.39.17-1~deb12u1
    Published Updated
  2. CVE-2025-61641

    Low · CVSS 1.7EPSS 0.32%Fix available

    API list=allpages with maxsize is making really slow queries

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/api/ApiQueryAllPages.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.

    • Update to 1:1.39.17-1~deb12u1
    Published Updated
  3. CVE-2025-61643

    Low · CVSS 2.7EPSS 0.27%Fix available

    EventStreams publishes suppressed recent change entries that are suppressed from their creation

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/recentchanges/RecentChangeRCFeedNotifier.Php. This issue affects MediaWiki: from * before 1.39.14, 1.43.4, 1.44.1.

    • Update to 1:1.39.17-1~deb12u1
    Published Updated
  4. CVE-2025-61635

    Low · CVSS 0EPSS 0.4%Fix available

    Add rate limiting to ApiFancyCaptchaReload

    Vulnerability in Wikimedia Foundation ConfirmEdit. This vulnerability is associated with program files includes/FancyCaptcha/ApiFancyCaptchaReload.Php. This issue affects ConfirmEdit: *.

    • Update to 1:1.39.17-1~deb12u1
    Published Updated
  5. CVE-2025-6590

    Medium · CVSS 4.6EPSS 0.37%Fix available

    Complete content leak of private wikis due to PasswordReset Wikitext injection in error message

    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLUserTextField.Php. This issue affects MediaWiki: from * through 1.39.12, 1.42.76 1.43.1, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  6. CVE-2025-6591

    Low · CVSS 0EPSS 0.45%Fix available

    HTML injection in API action=feedcontributions output from i18n message

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/api/ApiFeedContributions.Php. This issue affects MediaWiki: from * before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  7. CVE-2025-6593

    Low · CVSS 2.1EPSS 0.45%Fix available

    "{{SITENAME}} registered email address has been changed" email sent to unverified email addresses

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/user/User.Php. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  8. CVE-2025-6594

    Low · CVSS 0EPSS 0.32%Fix available

    XSS in Special:ApiSandbox

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Special.Apisandbox/ApiSandbox.Js. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  9. CVE-2025-6595

    Low · CVSS 0EPSS 0.32%Fix available

    CVE-2025-6595

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MultimediaViewer.This issue affects MultimediaViewer: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  10. CVE-2025-6597

    Low · CVSS 0EPSS 0.52%Fix available

    MediaWiki should not consider autocreation as login for the purposes of security reauthentication

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/auth/AuthManager.Php. This issue affects MediaWiki: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  11. CVE-2025-6926

    High · CVSS 8.8EPSS 0.45%Fix available

    Security Authentication Bypass in CentralAuth

    Improper Authentication vulnerability in Wikimedia Foundation Mediawiki - CentralAuth Extension allows : Bypass Authentication.This issue affects Mediawiki - CentralAuth Extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

    • Update to 1:1.39.13-1~deb12u1
    Published Updated
  12. CVE-2025-32698

    Low · CVSS 2.1EPSS 0.43%Fix available

    LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions

    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.39.12-1~deb12u1
    Published Updated
  13. CVE-2025-32697

    Low · CVSS 0EPSS 0.39%No fix published

    Cascading protection is not preventing file reversions

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, includes/Permissions/RestrictionStore.Php. This issue affects MediaWiki: before 1.42.6, 1.43.1.

    Published Updated
  14. CVE-2025-32696

    Low · CVSS 0EPSS 0.36%Fix available

    "reupload-own" restriction can be bypassed by reverting file

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/actions/RevertAction.Php, includes/api/ApiFileRevert.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.39.12-1~deb12u1
    Published Updated
  15. CVE-2025-3469

    Low · CVSS 0EPSS 0.44%Fix available

    i18n XSS vulnerability in HTMLMultiSelectField when sections are used

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLMultiSelectField.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.39.12-1~deb12u1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →