p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 5

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 283

  1. CVE-2020-36649

    Low · CVSS 3.5EPSS 1.43%Fix available

    mholt PapaParse papaparse.js redos

    A vulnerability was found in mholt PapaParse up to 5.1.x. It has been classified as problematic. Affected is an unknown function of the file papaparse.js. The manipulation leads to inefficient regular expression complexity. Upgrading to version 5.2.0 is able to address this issue. The name of the patch is 235a12758cd77266d2e98fd715f53536b34ad621. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218004.

    • Update to 1:1.39.4-1~deb12u1
    Published Updated
  2. CVE-2022-41767

    Medium · CVSS 5.3EPSS 0.69%Fix available

    CVE-2022-41767

    An issue was discovered in MediaWiki before 1.35.8, 1.36.x and 1.37.x before 1.37.5, and 1.38.x before 1.38.3. When changes made by an IP address are reassigned to a user (using reassignEdits.php), the changes will still be attributed to the IP address on Special:Contributions when doing a range lookup.

    • Update to 1:1.35.8-1
    Published Updated
  3. CVE-2022-34911

    Medium · CVSS 6.1EPSS 1.08%Fix available

    CVE-2022-34911

    An issue was discovered in MediaWiki before 1.35.7, 1.36.x and 1.37.x before 1.37.3, and 1.38.x before 1.38.1. XSS can occur in configurations that allow a JavaScript payload in a username. After account creation, when it sets the page title to "Welcome" followed by the username, the username is not escaped: SpecialCreateAccount::successfulAction() calls ::showSuccessPage() with a message as second parameter, and OutputPage::setPageTitle() uses text().

    • Update to 1:1.35.7-1
    Published Updated
  4. CVE-2022-31091

    High · CVSS 7.7EPSS 1.57%Fix available

    Change in port should be considered a change in origin in Guzzle

    Guzzle, an extensible PHP HTTP client. `Authorization` and `Cookie` headers on requests are sensitive information. In affected versions on making a request which responds with a redirect to a URI with a different port, if we choose to follow it, we should remove the `Authorization` and `Cookie` headers from the request, before containing. Previously, we would only consider a change in host or scheme. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Guzzle should upgrade to Guzzle 6.5.8 or 7.4.5. Note that a partial fix was implemented in Guzzle 7.4.2, where a change in host

    • Update to 1:1.35.7-1
    Published Updated
  5. CVE-2022-31090

    High · CVSS 7.7EPSS 1.92%Fix available

    CURLOPT_HTTPAUTH option not cleared on change of origin in Guzzle

    Guzzle, an extensible PHP HTTP client. `Authorization` headers on requests are sensitive information. In affected versions when using our Curl handler, it is possible to use the `CURLOPT_HTTPAUTH` option to specify an `Authorization` header. On making a request which responds with a redirect to a URI with a different origin (change in host, scheme or port), if we choose to follow it, we should remove the `CURLOPT_HTTPAUTH` option before continuing, stopping curl from appending the `Authorization` header to the new request. Affected Guzzle 7 users should upgrade to Guzzle 7.4.5 as soon as possible. Affected users using any earlier series of Gu

    • Update to 1:1.35.7-1
    Published Updated
  6. CVE-2022-31043

    High · CVSS 7.5EPSS 1.96%Fix available

    Fix failure to strip Authorization header on HTTP downgrade in Guzzle

    Guzzle is an open source PHP HTTP client. In affected versions `Authorization` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, we should not forward the `Authorization` header on. This is much the same as to how we don't forward on the header if the host changes. Prior to this fix, `https` to `http` downgrades did not result in the `Authorization` header being removed, only changes to the host. Affected Guzzle 7 users should upgrade to Guzzle 7.4.4 as soon as possible. Affected users using any earlier series of Guzzle should

    • Update to 1:1.35.7-1
    Published Updated
  7. CVE-2022-31042

    High · CVSS 7.5EPSS 1.96%Fix available

    Failure to strip the Cookie header on change in host or HTTP downgrade in Guzzle

    Guzzle is an open source PHP HTTP client. In affected versions the `Cookie` headers on requests are sensitive information. On making a request using the `https` scheme to a server which responds with a redirect to a URI with the `http` scheme, or on making a request to a server which responds with a redirect to a a URI to a different host, we should not forward the `Cookie` header on. Prior to this fix, only cookies that were managed by our cookie middleware would be safely removed, and any `Cookie` header manually added to the initial request would not be stripped. We now always strip it, and allow the cookie middleware to re-add any cookies

    • Update to 1:1.35.7-1
    Published Updated
  8. CVE-2022-29248

    High · CVSS 8EPSS 1.36%Fix available

    Cross-domain cookie leakage in Guzzle

    Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple do

    • Update to 1:1.35.7-1
    Published Updated
  9. CVE-2017-0371

    High · CVSS 7.5EPSS 1.57%Fix available

    CVE-2017-0371

    MediaWiki before 1.23.16, 1.24.x through 1.27.x before 1.27.2, and 1.28.x before 1.28.1 allows remote attackers to discover the IP addresses of Wiki visitors via a style="background-image: attr(title url);" attack within a DIV element that has an attacker-controlled URL in the title attribute.

    • Update to 1:1.27.2-1
    Published Updated
  10. CVE-2021-44858

    High · CVSS 7.5EPSS 1.37%Fix available

    CVE-2021-44858

    An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. It is possible to use action=edit&undo= followed by action=mcrundo and action=mcrrestore to view private pages on a private wiki that has at least one page set in $wgWhitelistRead.

    • Update to 1:1.35.5-1
    Published Updated
  11. CVE-2021-44857

    Medium · CVSS 6.5EPSS 0.9%Fix available

    CVE-2021-44857

    An issue was discovered in MediaWiki before 1.35.5, 1.36.x before 1.36.3, and 1.37.x before 1.37.1. It is possible to use action=mcrundo followed by action=mcrrestore to replace the content of any arbitrary page (that the user doesn't have edit rights for). This applies to any public wiki, or a private wiki that has at least one page set in $wgWhitelistRead.

    • Update to 1:1.35.5-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →