p PatchFirst

PatchFirst · Latest vulnerabilities

nodejs vulnerabilities · Page 6

Vulnerabilities published for nodejs in the last 30 days: 7. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 112

  1. CVE-2017-11499

    High · CVSS 7.5EPSS 5.43%Fix available

    CVE-2017-11499

    Node.js v4.0 through v4.8.3, all versions of v5.x, v6.0 through v6.11.0, v7.0 through v7.10.0, and v8.0 through v8.1.3 was susceptible to hash flooding remote DoS attacks as the HashTable seed was constant across a given released version of Node.js. This was a result of building with V8 snapshots enabled by default which caused the initially randomized seed to be overwritten on startup.

    • Update to 4.8.4~dfsg-1
    Published Updated
  2. CVE-2016-7099

    Medium · CVSS 5.9EPSS 2.84%Fix available

    CVE-2016-7099

    The tls.checkServerIdentity function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 does not properly handle wildcards in name fields of X.509 certificates, which allows man-in-the-middle attackers to spoof servers via a crafted certificate.

    • Update to 4.6.0~dfsg-1
    Published Updated
  3. CVE-2016-5325

    Medium · CVSS 6.1EPSS 4.09%Fix available

    CVE-2016-5325

    CRLF injection vulnerability in the ServerResponse#writeHead function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the reason argument.

    • Update to 4.6.0~dfsg-1
    Published Updated
  4. CVE-2016-1669

    High · CVSS 8.8EPSS 4.23%Fix available

    CVE-2016-1669

    The Zone::New function in zone.cc in Google V8 before 5.0.71.47, as used in Google Chrome before 50.0.2661.102, does not properly determine when to expand certain memory allocations, which allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact via crafted JavaScript code.

    • Update to 4.4.6~dfsg-1
    Published Updated
  5. CVE-2016-2216

    High · CVSS 7.5EPSS 7.26%Fix available

    CVE-2016-2216

    The HTTP header parsing code in Node.js 0.10.x before 0.10.42, 0.11.6 through 0.11.16, 0.12.x before 0.12.10, 4.x before 4.3.0, and 5.x before 5.6.0 allows remote attackers to bypass an HTTP response-splitting protection mechanism via UTF-8 encoded Unicode characters in the HTTP header, as demonstrated by %c4%8d%c4%8a.

    • Update to 4.3.0~dfsg-1
    Published Updated
  6. CVE-2015-6764

    Critical · CVSS 9.8EPSS 5.73%Fix available

    CVE-2015-6764

    The BasicJsonStringifier::SerializeJSArray function in json-stringifier.h in the JSON stringifier in Google V8, as used in Google Chrome before 47.0.2526.73, improperly loads array elements, which allows remote attackers to cause a denial of service (out-of-bounds memory access) or possibly have unspecified other impact via crafted JavaScript code.

    • Update to 4.2.3~dfsg-1
    Published Updated
  7. CVE-2014-5256

    Not ratedEPSS 3.29%Fix available

    CVE-2014-5256

    Node.js 0.8 before 0.8.28 and 0.10 before 0.10.30 does not consider the possibility of recursive processing that triggers V8 garbage collection in conjunction with a V8 interrupt, which allows remote attackers to cause a denial of service (memory corruption and application crash) via deep JSON objects whose parsing lets this interrupt mask an overflow of the program stack.

    • Update to 0.10.38~dfsg-1
    Published Updated
  8. CVE-2012-2330

    Not ratedEPSS 2.6%Fix available

    CVE-2012-2330

    The Update method in src/node_http_parser.cc in Node.js before 0.6.17 and 0.7 before 0.7.8 does not properly check the length of a string, which allows remote attackers to obtain sensitive information (request header contents) and possibly spoof HTTP headers via a zero length string.

    • Update to 0.6.17~dfsg1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →