p PatchFirst

PatchFirst · Latest vulnerabilities

vlc vulnerabilities · Page 5

Vulnerability published for vlc in the last 30 days: 1. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 127

  1. CVE-2011-2587

    Not ratedEPSS 3.69%Fix available

    CVE-2011-2587

    Heap-based buffer overflow in the DemuxAudioSipr function in real.c in the RealMedia demuxer in VideoLAN VLC media player 1.1.x before 1.1.11 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Real Media file.

    • Update to 1.1.11-1
    Published Updated
  2. CVE-2011-0531

    Not ratedEPSS 41.85%Public exploitFix available

    CVE-2011-0531

    demux/mkv/mkv.hpp in the MKV demuxer plugin in VideoLAN VLC media player 1.1.6.1 and earlier allows remote attackers to cause a denial of service (crash) and execute arbitrary commands via a crafted MKV (WebM or Matroska) file that triggers memory corruption, related to "class mismatching" and the MKV_IS_ID macro.

    • Update to 1.1.7-1
    Published Updated
  3. CVE-2011-0522

    Not ratedEPSS 51.54%Public exploitFix available

    CVE-2011-0522

    The StripTags function in (1) the USF decoder (modules/codec/subtitles/subsdec.c) and (2) the Text decoder (modules/codec/subtitles/subsusf.c) in VideoLAN VLC Media Player 1.1 before 1.1.6-rc allows remote attackers to execute arbitrary code via a subtitle with an opening "<" without a closing ">" in an MKV file, which triggers heap memory corruption, as demonstrated using refined-australia-blu720p-sample.mkv.

    • Update to 1.1.3-1squeeze2
    Published Updated
  4. CVE-2010-3907

    Not ratedEPSS 5.83%Fix available

    CVE-2010-3907

    Multiple integer overflows in real.c in the Real demuxer plugin in VideoLAN VLC Media Player before 1.1.6 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a zero i_subpackets value in a Real Media file, leading to a heap-based buffer overflow.

    • Update to 1.1.3-1squeeze1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →