p PatchFirst

PatchFirst · Latest vulnerabilities

expat vulnerabilities · Page 2

Vulnerabilities published for expat in the last 30 days: 4. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 70

  1. CVE-2026-56131

    Medium · CVSS 4.9EPSS 0.18%Fix available

    CVE-2026-56131

    libexpat before 2.8.2 lacks handler call depth tracking for calls to XML_ResumeParser from within handlers in cases of a policy violation. Thus, a use-after-free can occur (similar to the CVE-2026-50219 situation).

    • Update to 2.8.2-1~deb13u1
    Published Updated
  2. CVE-2026-50219

    Medium · CVSS 4.9EPSS 0.18%Fix available

    CVE-2026-50219

    libexpat before 2.8.2 lacks handler call depth tracking for calls to XML_GetBuffer, XML_Parse, XML_ParseBuffer, XML_ParserFree, or XML_ParserReset from within handlers in cases of a policy violation. Thus, a use-after-free can occur,

    • Update to 2.8.2-1~deb13u1
    Published Updated
  3. CVE-2024-8176

    High · CVSS 7.5EPSS 1.35%Public exploitFix available

    Libexpat: expat: improper restriction of xml entity expansion depth in libexpat

    A stack overflow vulnerability exists in the libexpat library due to the way it handles recursive entity expansion in XML documents. When parsing an XML document with deeply nested entity references, libexpat can be forced to recurse indefinitely, exhausting the stack space and causing a crash. This issue could lead to denial of service (DoS) or, in some cases, exploitable memory corruption, depending on the environment and library usage.

    • Update to 2.7.0-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →