p PatchFirst

PatchFirst · Latest vulnerabilities

expat vulnerabilities · Page 4

Vulnerabilities published for expat in the last 30 days: 4. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 70

  1. CVE-2016-4472

    High · CVSS 8.1EPSS 11.95%Fix available

    CVE-2016-4472

    The overflow protection in Expat is removed by compilers with certain optimization settings, which allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via crafted XML data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-1283 and CVE-2015-2716.

    • Update to 2.1.1-2
    Published Updated
  2. CVE-2016-5300

    High · CVSS 7.5EPSS 6.54%Fix available

    CVE-2016-5300

    The XML parser in Expat does not use sufficient entropy for hash initialization, which allows context-dependent attackers to cause a denial of service (CPU consumption) via crafted identifiers in an XML document. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-0876.

    • Update to 2.1.1-3
    Published Updated
  3. CVE-2015-1283

    Not ratedEPSS 18.44%Fix available

    CVE-2015-1283

    Multiple integer overflows in the XML_GetBuffer function in Expat through 2.1.0, as used in Google Chrome before 44.0.2403.89 and other products, allow remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted XML data, a related issue to CVE-2015-2716.

    • Update to 2.1.0-7
    Published Updated
  4. CVE-2013-0340

    Not ratedEPSS 19.43%Fix available

    CVE-2013-0340

    expat before version 2.4.0 does not properly handle entities expansion unless an application developer uses the XML_SetEntityDeclHandler function, which allows remote attackers to cause a denial of service (resource consumption), send HTTP requests to intranet servers, or read arbitrary files via a crafted XML document, aka an XML External Entity (XXE) issue. NOTE: it could be argued that because expat already provides the ability to disable external entity expansion, the responsibility for resolving this issue lies with application developers; according to this argument, this entry should be REJECTed, and each affected application would nee

    • Update to 2.4.1-2
    Published Updated
  5. CVE-2012-1148

    Not ratedEPSS 3.47%Fix available

    CVE-2012-1148

    Memory leak in the poolGrow function in expat/lib/xmlparse.c in expat before 2.1.0 allows context-dependent attackers to cause a denial of service (memory consumption) via a large number of crafted XML files that cause improperly-handled reallocation failures when expanding entities.

    • Update to 2.1.0~beta3-1
    Published Updated
  6. CVE-2012-0876

    Not ratedEPSS 5.72%Fix available

    CVE-2012-0876

    The XML parser (xmlparse.c) in expat before 2.1.0 computes hash values without restricting the ability to trigger hash collisions predictably, which allows context-dependent attackers to cause a denial of service (CPU consumption) via an XML file with many identifiers with the same value.

    • Update to 2.1.0~beta3-1
    Published Updated
  7. CVE-2009-3560

    Not ratedEPSS 24.31%Fix available

    CVE-2009-3560

    The big2_toUtf8 function in lib/xmltok.c in libexpat in Expat 2.0.1, as used in the XML-Twig module for Perl, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with malformed UTF-8 sequences that trigger a buffer over-read, related to the doProlog function in lib/xmlparse.c, a different vulnerability than CVE-2009-2625 and CVE-2009-3720.

    • Update to 2.0.1-6
    Published Updated
  8. CVE-2009-3720

    Not ratedEPSS 27.92%Fix available

    CVE-2009-3720

    The updatePosition function in lib/xmltok_impl.c in libexpat in Expat 2.0.1, as used in Python, PyXML, w3c-libwww, and other software, allows context-dependent attackers to cause a denial of service (application crash) via an XML document with crafted UTF-8 sequences that trigger a buffer over-read, a different vulnerability than CVE-2009-2625.

    • Update to 2.0.1-5
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →