p PatchFirst

PatchFirst · Latest vulnerabilities

firefox-esr vulnerabilities · Page 55

Vulnerabilities published for firefox-esr in the last 30 days: 206. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 1358

  1. CVE-2019-13075

    Medium · CVSS 5.3EPSS 1.86%Fix available

    CVE-2019-13075

    Tor Browser through 8.5.3 has an information exposure vulnerability. It allows remote attackers to detect the browser's language via vectors involving an IFRAME element, because text in that language is included in the title attribute of a LINK element for a non-HTML page. This is related to a behavior of Firefox before 68.

    • Update to 68.2.0esr-1
    Published Updated
  2. CVE-2019-9796

    Critical · CVSS 9.8EPSS 2.06%Fix available

    CVE-2019-9796

    A use-after-free vulnerability can occur when the SMIL animation controller incorrectly registers with the refresh driver twice when only a single registration is expected. When a registration is later freed with the removal of the animation controller element, the refresh driver incorrectly leaves a dangling pointer to the driver's observer array. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  3. CVE-2019-9793

    Medium · CVSS 5.9EPSS 1.63%Fix available

    CVE-2019-9793

    A mechanism was discovered that removes some bounds checking for string, array, or typed array accesses if Spectre mitigations have been disabled. This vulnerability could allow an attacker to create an arbitrary value in compiled JavaScript, for which the range analysis will infer a fully controlled, incorrect range in circumstances where users have explicitly disabled Spectre mitigations. *Note: Spectre mitigations are currently enabled for all users by default settings.*. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  4. CVE-2019-9792

    Critical · CVSS 9.8EPSS 13.3%Public exploitFix available

    CVE-2019-9792

    The IonMonkey just-in-time (JIT) compiler can leak an internal JS_OPTIMIZED_OUT magic value to the running script during a bailout. This magic value can then be used by JavaScript to achieve memory corruption, which results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  5. CVE-2019-9791

    Critical · CVSS 9.8EPSS 19.91%Public exploitFix available

    CVE-2019-9791

    The type inference system allows the compilation of functions that can cause type confusions between arbitrary objects when compiled through the IonMonkey just-in-time (JIT) compiler and when the constructor function is entered through on-stack replacement (OSR). This allows for possible arbitrary reading and writing of objects during an exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  6. CVE-2019-9790

    Critical · CVSS 9.8EPSS 1.85%Fix available

    CVE-2019-9790

    A use-after-free vulnerability can occur when a raw pointer to a DOM element on a page is obtained using JavaScript and the element is then removed while still in use. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated
  7. CVE-2019-9788

    Critical · CVSS 9.8EPSS 2.24%Fix available

    CVE-2019-9788

    Mozilla developers and community members reported memory safety bugs present in Firefox 65, Firefox ESR 60.5, and Thunderbird 60.5. Some of these bugs showed evidence of memory corruption and we presume that with enough effort that some of these could be exploited to run arbitrary code. This vulnerability affects Thunderbird < 60.6, Firefox ESR < 60.6, and Firefox < 66.

    • Update to 60.6.0esr-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →