p PatchFirst

PatchFirst · Latest vulnerabilities

mediawiki vulnerabilities · Page 4

Vulnerabilities published for mediawiki in the last 30 days: 9. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 295

  1. CVE-2025-6593

    Low · CVSS 2.1EPSS 0.45%Fix available

    "{{SITENAME}} registered email address has been changed" email sent to unverified email addresses

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/user/User.Php. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  2. CVE-2025-6594

    Low · CVSS 0EPSS 0.32%Fix available

    XSS in Special:ApiSandbox

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files resources/src/mediawiki.Special.Apisandbox/ApiSandbox.Js. This issue affects MediaWiki: from 1.27.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  3. CVE-2025-6595

    Low · CVSS 0EPSS 0.32%Fix available

    CVE-2025-6595

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MultimediaViewer.This issue affects MultimediaViewer: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  4. CVE-2025-6596

    Low · CVSS 0EPSS 0.44%Fix available

    Vector inserts portlet labels as HTML, allowing for stored XSS through system messages

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation Vector. This vulnerability is associated with program files resources/skins.Vector.Js/portlets.Js, resources/skins.Vector.Legacy.Js/portlets.Js. This issue affects Vector: from >= 1.40.0 before 1.42.7, 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  5. CVE-2025-6597

    Low · CVSS 0EPSS 0.52%Fix available

    MediaWiki should not consider autocreation as login for the purposes of security reauthentication

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/auth/AuthManager.Php. This issue affects MediaWiki: from * before 1.39.13, 1.42.7, 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  6. CVE-2025-6927

    Low · CVSS 2.3EPSS 0.52%Fix available

    Autoblocks from global account suppressions are publicly visible

    Vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/specials/pagers/BlockListPager.Php, includes/api/ApiQueryBlocks.Php. This issue affects MediaWiki: from >= 1.42.0 before 1.39.13, 1.42.7 1.43.2, 1.44.0.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  7. CVE-2025-11175

    High · CVSS 8.8EPSS 0.47%Fix available

    DiscussionTools should use better regex

    Improper Neutralization of Special Elements used in an Expression Language Statement ('Expression Language Injection') vulnerability in The Wikimedia Foundation Mediawiki - DiscussionTools Extension allows Regular Expression Exponential Blowup.This issue affects Mediawiki - DiscussionTools Extension: 1.44, 1.43.

    • Update to 1:1.43.6+dfsg-1~deb13u1
    Published Updated
  8. CVE-2025-6926

    High · CVSS 8.8EPSS 0.45%Fix available

    Security Authentication Bypass in CentralAuth

    Improper Authentication vulnerability in Wikimedia Foundation Mediawiki - CentralAuth Extension allows : Bypass Authentication.This issue affects Mediawiki - CentralAuth Extension: from 1.39.X before 1.39.13, from 1.42.X before 1.42.7, from 1.43.X before 1.43.2.

    • Update to 1:1.43.3+dfsg-1
    Published Updated
  9. CVE-2025-32700

    Low · CVSS 2.3EPSS 0.43%Fix available

    AbuseFilter log interfaces expose global private and hidden filters when central DB is not available

    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation AbuseFilter. This vulnerability is associated with program files includes/Api/QueryAbuseLog.Php, includes/Pager/AbuseLogPager.Php, includes/Special/SpecialAbuseLog.Php, includes/View/AbuseFilterViewExamine.Php. This issue affects AbuseFilter: from >= 1.43.0 before 1.43.1.

    • Update to 1:1.43.1+dfsg-1
    Published Updated
  10. CVE-2025-32698

    Low · CVSS 2.1EPSS 0.43%Fix available

    LogPager.php: Restriction enforcer functions do not correctly enforce suppression restrictions

    Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/logging/LogPager.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.43.1+dfsg-1
    Published Updated
  11. CVE-2025-32697

    Low · CVSS 0EPSS 0.39%Fix available

    Cascading protection is not preventing file reversions

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/editpage/IntroMessageBuilder.Php, includes/Permissions/PermissionManager.Php, includes/Permissions/RestrictionStore.Php. This issue affects MediaWiki: before 1.42.6, 1.43.1.

    • Update to 1:1.43.1+dfsg-1
    Published Updated
  12. CVE-2025-32696

    Low · CVSS 0EPSS 0.36%Fix available

    "reupload-own" restriction can be bypassed by reverting file

    Improper Preservation of Permissions vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/actions/RevertAction.Php, includes/api/ApiFileRevert.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.43.1+dfsg-1
    Published Updated
  13. CVE-2025-3469

    Low · CVSS 0EPSS 0.44%Fix available

    i18n XSS vulnerability in HTMLMultiSelectField when sections are used

    Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Wikimedia Foundation MediaWiki. This vulnerability is associated with program files includes/htmlform/fields/HTMLMultiSelectField.Php. This issue affects MediaWiki: before 1.39.12, 1.42.6, 1.43.1.

    • Update to 1:1.43.1+dfsg-1
    Published Updated
  14. CVE-2024-47913

    Medium · CVSS 5.3EPSS 0.45%Fix available

    CVE-2024-47913

    An issue was discovered in the AbuseFilter extension for MediaWiki before 1.39.9, 1.40.x and 1.41.x before 1.41.3, and 1.42.x before 1.42.2. An API caller can match a filter condition against AbuseFilter logs even if the caller is not authorized to view the log details for the filter.

    • Update to 1:1.39.10-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →