p PatchFirst

PatchFirst · Latest vulnerabilities

postgresql-18 vulnerabilities · Page 3

Vulnerabilities published for postgresql-18 in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 46

  1. CVE-2026-2006

    High · CVSS 8.8EPSS 1.16%Fix available

    PostgreSQL missing validation of multibyte character length executes arbitrary code

    Missing validation of multibyte character length in PostgreSQL text manipulation allows a database user to issue crafted queries that achieve a buffer overrun. That suffices to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

    • Update to 18.2-1
    Published Updated
  2. CVE-2026-2005

    High · CVSS 8.8EPSS 1.37%Public exploitFix available

    PostgreSQL pgcrypto heap buffer overflow executes arbitrary code

    Heap buffer overflow in PostgreSQL pgcrypto allows a ciphertext provider to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

    • Update to 18.2-1
    Published Updated
  3. CVE-2026-2004

    High · CVSS 8.8EPSS 1.34%Fix available

    PostgreSQL intarray missing validation of type of input to selectivity estimator executes arbitrary code

    Missing validation of type of input in PostgreSQL intarray extension selectivity estimator function allows an object creator to execute arbitrary code as the operating system user running the database. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

    • Update to 18.2-1
    Published Updated
  4. CVE-2026-2003

    Medium · CVSS 4.3EPSS 0.32%Fix available

    PostgreSQL oidvector discloses a few bytes of memory

    Improper validation of type "oidvector" in PostgreSQL allows a database user to disclose a few bytes of server memory. We have not ruled out viability of attacks that arrange for presence of confidential information in disclosed bytes, but they seem unlikely. Versions before PostgreSQL 18.2, 17.8, 16.12, 15.16, and 14.21 are affected.

    • Update to 18.2-1
    Published Updated
  5. CVE-2025-12818

    Medium · CVSS 5.9EPSS 0.36%Fix available

    PostgreSQL libpq undersizes allocations, via integer wraparound

    Integer wraparound in multiple PostgreSQL libpq client library functions allows an application input provider or network peer to cause libpq to undersize an allocation and write out-of-bounds by hundreds of megabytes. This results in a segmentation fault for the application using libpq. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.

    • Update to 18.1-1
    Published Updated
  6. CVE-2025-12817

    Low · CVSS 3.1EPSS 0.24%Fix available

    PostgreSQL CREATE STATISTICS does not check for schema CREATE privilege

    Missing authorization in PostgreSQL CREATE STATISTICS command allows a table owner to achieve denial of service against other CREATE STATISTICS users by creating in any schema. A later CREATE STATISTICS for the same name, from a user having the CREATE privilege, would then fail. Versions before PostgreSQL 18.1, 17.7, 16.11, 15.15, 14.20, and 13.23 are affected.

    • Update to 18.1-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →