p PatchFirst

PatchFirst · Latest vulnerabilities

webkit2gtk vulnerabilities · Page 38

Vulnerabilities published for webkit2gtk in the last 30 days: 0. Listed in the KEV catalogue: 0.

Filter vulnerabilities
Clear filters

Vulnerabilities: 960

  1. CVE-2019-8375

    Critical · CVSS 9.8EPSS 15.7%Public exploitFix available

    CVE-2019-8375

    The UIProcess subsystem in WebKit, as used in WebKitGTK through 2.23.90 and WebKitGTK+ through 2.22.6 and other products, does not prevent the script dialog size from exceeding the web view size, which allows remote attackers to cause a denial of service (Buffer Overflow) or possibly have unspecified other impact, related to UIProcess/API/gtk/WebKitScriptDialogGtk.cpp, UIProcess/API/gtk/WebKitScriptDialogImpl.cpp, and UIProcess/API/gtk/WebKitWebViewGtk.cpp, as demonstrated by GNOME Web (aka Epiphany).

    • Update to 2.24.1-1
    Published Updated
  2. CVE-2018-12293

    High · CVSS 8.8EPSS 10.03%Public exploitFix available

    CVE-2018-12293

    The getImageData function in the ImageBufferCairo class in WebCore/platform/graphics/cairo/ImageBufferCairo.cpp in WebKit, as used in WebKitGTK+ prior to version 2.20.3 and WPE WebKit prior to version 2.20.1, is vulnerable to a heap-based buffer overflow triggered by an integer overflow, which could be abused by crafted HTML content.

    • Update to 2.20.3-1
    Published Updated
  3. CVE-2018-4246

    High · CVSS 8.8EPSS 2.97%Fix available

    CVE-2018-4246

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages type confusion.

    • Update to 2.20.4-1
    Published Updated
  4. CVE-2018-4233

    High · CVSS 8.8EPSS 53.82%Public exploitFix available

    CVE-2018-4233

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

    • Update to 2.20.3-1
    Published Updated
  5. CVE-2018-4232

    Medium · CVSS 4.3EPSS 2.08%Fix available

    CVE-2018-4232

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. The issue involves the "WebKit" component. It allows remote attackers to overwrite cookies via a crafted web site.

    • Update to 2.20.3-1
    Published Updated
  6. CVE-2018-4222

    High · CVSS 8.8EPSS 10.17%Public exploitFix available

    CVE-2018-4222

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code via a crafted web site that leverages a getWasmBufferFromValue out-of-bounds read during WebAssembly compilation.

    • Update to 2.20.3-1
    Published Updated
  7. CVE-2018-4218

    High · CVSS 8.8EPSS 9.05%Public exploitFix available

    CVE-2018-4218

    An issue was discovered in certain Apple products. iOS before 11.4 is affected. Safari before 11.1.1 is affected. iCloud before 7.5 on Windows is affected. iTunes before 12.7.5 on Windows is affected. tvOS before 11.4 is affected. watchOS before 4.3.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site that triggers an @generatorState use-after-free.

    • Update to 2.20.3-1
    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →