p PatchFirst

PatchFirst · Latest vulnerabilities

Latest vulnerabilities · Page 79

Follow new advisories by stack, product and installed version. Vulnerabilities published or escalated in the last 30 days: 20150. Listed in KEV: 80.

Filter vulnerabilities
Clear filters

Early warnings

Fresh vulnerability reports from vendor announcements and security news. These warnings do not change the security rating.

  1. node.js

    No fix published

    Node.js: denial of service

    According to GitHub Advisory Database, Node.js has a denial of service vulnerability (CVE-2026-109932). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a Node.js update with the fix is available and install it.

    CVE-2026-109932

  2. node.js

    No fix published

    Node.js: remote code execution

    According to OpenNet, Node.js has a remote code execution vulnerability (CVE-2026-111497). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a Node.js update with the fix is available and install it.

    CVE-2026-111497

  3. php

    No fix published

    PHP: remote code execution

    According to OpenNet, PHP has a remote code execution vulnerability (CVE-2026-115560). The exact affected versions are unspecified. The report does not name a fixed version.

    What to do now: Check whether a PHP update with the fix is available and install it.

    CVE-2026-115560

Vulnerabilities: 488306

  1. ALSA-2026:88349

    Not ratedFix available

    Important: java-21-openjdk security update for AlmaLinux 8 and 9

    The OpenJDK 21 packages provide the OpenJDK 21 Java Runtime Environment and the OpenJDK 21 Java Software Development Kit. Security Fix(es): * JDK: Enhance PKCS5 padding (CVE-2026-83374) * JDK: Enhance TLS certificate handling (CVE-2026-83376) * JDK: Improve C2 loop transformations (CVE-2026-83378) * JDK: Enhance LDAP logins (CVE-2026-83380) * JDK: Enhance SASL Authentication (CVE-2026-83381) * JDK: Enhance WebRowSets (CVE-2026-83387) * JDK: Enhance HTTP Client Response Handling (CVE-2026-83395) * JDK: Enhance XML Processing (CVE-2026-83400) * JDK: Enhance XPath Expressions (CVE-2026-87290) * JDK: Enhance HTTP Server

    • Update to 1:21.0.13.0.9-1.1.el8
    • Update to 1:21.0.13.0.9-1.2.el9.alma.1
    Published Updated
  2. CVE-2026-79589

    Not ratedEPSS 0.18%No fix published

    CVE-2026-79589

    The WIFI4 N300 router (Model: T1 Pro) v1.0.0 by U-speed contains an insecure access control flaw that allows an attacker to gain unauthenticated root shell. The vulnerability is caused by the exposure of the UART debugging interface having a lack of authentication, authorization and access control functionality. Once the interface is soldered and connected to the attacker, they gain root privilege to the system.

    Published Updated
  3. CVE-2026-51905

    High · CVSS 8.8EPSS 0.38%No fix published

    CVE-2026-51905

    TransformerOptimus SuperAGI v0.0.14 is vulnerable to Incorrect Access Control in get_agent_execution_configuration in superagi/controllers/agent_execution_config.py. A remote authenticated attacker from one organization can read another organization's agent execution configuration by supplying the victim agent_id and agent_execution_id to /agent_executions_configs/details/agent_id/{agent_id}/agent_execution_id/{agent_execution_id}. The endpoint lacks an organization ownership check on the selected agent and execution.

    Published Updated
  4. CVE-2026-51903

    Not ratedEPSS 0.26%No fix published

    CVE-2026-51903

    SuperAGI v0.0.14 contains an improper access control vulnerability in get_agent_by_latest_execution in superagi/controllers/agent_execution.py. A remote authenticated attacker from one organization can retrieve latest execution and agent metadata for another organization's project through /agentexecutions/get/latest/agent/project/{project_id} by supplying a victim project_id.

    Published Updated
  5. CVE-2026-51902

    Not ratedEPSS 0.14%No fix published

    CVE-2026-51902

    SuperAGI up to v0.0.14 contains an improper access control vulnerability. The agent controller endpoint /api/agents/get/project/{project_id} allows authenticated users from one organization to retrieve the complete list of agents belonging to a different organization's project. The endpoint accepts a project_id parameter but does not verify that the project belongs to the authenticated user's organization.

    Published Updated
  6. CVE-2026-51863

    Not ratedEPSS 0.37%No fix published

    CVE-2026-51863

    DB-GPT v0.7.5 and 0.8.0 contains directory traversal in use_example_file (packages/dbgpt-app/src/dbgpt_app/openapi/api_v1/examples_api.py:129). A remote attacker can use the validated exploitation path to write files outside the intended workspace or storage boundary.

    Published Updated
  7. CVE-2026-51851

    Not ratedEPSS 0.24%No fix published

    CVE-2026-51851

    modelscope agent-zero 1.7, 1.8, 1.9, and 1.10 is vulnerable to Directory Traversal in python/helpers/file_browser.py:FileBrowser.save_text_file. The save_text_file method accepts user-controlled file paths without normalization or validation, allowing path traversal attacks.

    Published Updated
  8. CVE-2026-107056

    Not ratedEPSS 0.15%No fix published

    CVE-2026-107056

    Insecure permissions in the io.file.importer.ImportActivity component of OpenTracks versionCode 6751 allows unauthorized attackers to inject crafted tracking data into the victim's location database via a crafted SEND message.

    Published Updated

Check your server

Check your installed stack and versions against the current vulnerability feeds.

Check your server →