p PatchFirst

GHSA-265q-222x-52m6

GHSA-265q-222x-52m6 · silverstripe/framework has potential SQL Injection vulnerability in PostgreSQL database connector

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A potential SQL injection vulnerability was identified by using the silverstripe/postgresql database adapter. While unlikely to be exploitable, we have patched silverstripe/framework to ensure that table names are safely escaped before being passed to database adapters or user code.

CVSS 8.8 · High · Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/framework Packagist

    Versions
    • 4.0.0
    • 4.0.0-rc1
    • 4.0.0-rc2
    • 4.0.0-rc3
    • 4.0.1
    • 4.0.1-rc1
    • 4.0.2
    • 4.0.3
    • 4.0.4
    • 4.0.5
    Affected ranges
    • ECOSYSTEM: ≥ 4.0.0-rc1, < 4.0.6

    Update to 4.0.6

  • silverstripe/framework Packagist

    Versions
    • 4.1.0
    • 4.1.0-rc1
    • 4.1.0-rc2
    • 4.1.1
    • 4.1.2
    • 4.1.3
    Affected ranges
    • ECOSYSTEM: ≥ 4.1.0-rc1, < 4.1.4

    Update to 4.1.4

  • silverstripe/framework Packagist

    Versions
    • 4.2.0
    • 4.2.1
    • 4.2.2
    Affected ranges
    • ECOSYSTEM: ≥ 4.2.0-rc1, < 4.2.3

    Update to 4.2.3

Original sources

Check your server →