p PatchFirst

GHSA-2f4r-34m4-3w8q

GHSA-2f4r-34m4-3w8q · Auth0 Wordpress plugin Vulnerable to Brute Force Authentication Tags of CookieStore Sessions

This page contains facts from public vulnerability sources. Check the original advisory before updating.

**Overview** Session cookies of applications using the Auth0 Wordpress plugin configured with CookieStore have authentication tags that can be brute forced, which may result in unauthorized access. **Am I Affected?** You are affected by this vulnerability if you meet the following pre-conditions: 1. Applications using the Auth0 WordPress Plugin with version <=5.2.1 2. Auth0 WordPress Plugin uses the Auth0-PHP SDK with version 8.0.0-BETA1 or higher and below 8.14.0. 3. Session storage configured with CookieStore. **Fix** Upgrade Auth0/wordpress plugin to v5.3.0. As an additional precautionary measure, we recommend rotating your cookie encryption keys. Note that once updated, any previous session cookies will be rejected. **Acknowledgement** Okta would like to thank Félix Charette for discovering this vulnerability.

CVSS 9.1 · Critical · Fix available

Published
Updated

Stack: php

Affected products and versions

  • auth0/wordpress Packagist

    Versions
    • 2.0.0
    • 2.1.0
    • 2.1.1
    • 2.1.11
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    • 2.2.0
    • 3.1.1
    • 3.1.2
    • 3.1.3
    • 3.1.4
    • 3.10.0
    • 3.11.0
    • 3.11.1
    • 3.11.2
    • 3.11.3
    • 3.2.0
    • 3.2.10
    • 3.2.14
    • 3.2.19
    • 3.2.21
    • 3.2.22
    • 3.2.23
    • 3.2.24
    • 3.2.25
    • 3.2.5
    • 3.2.8
    • 3.2.9
    • 3.3.2
    • 3.4.0
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.6.1
    • 3.6.2
    • 3.7.0
    • 3.7.1
    • 3.7.3
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 4.0.0
    • 4.1.0
    • 4.1.1
    • 4.2.0
    • 4.3.0
    • 4.3.1
    • 4.4.0
    • 4.5.0
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 5.0.0
    • 5.0.0-BETA0
    • 5.0.0-BETA1
    • 5.0.1
    • 5.1.0
    • 5.2.0
    • 5.2.1
    Affected ranges
    • ECOSYSTEM: < 5.3.0

    Update to 5.3.0

Original sources

Check your server →