GHSA-2g98-f9jv-w8c5
GHSA-2g98-f9jv-w8c5 · robrichards/xmlseclibs XPath injection
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability has been identified in the robrichards/xmlseclibs library, specifically related to XPath injection. The issue arises from inadequate filtering of user input before it is incorporated into XPath expressions.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
robrichards/xmlseclibs Packagist
- Versions
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 2.0.0
- 2.0.1
- 2.1.0
- 2.1.1
- 3.0.0
- 3.0.1
- Affected ranges
- ECOSYSTEM: ≥ 1.0.0, < 3.0.2
Update to 3.0.2