GHSA-39h7-pwv7-rc3x
GHSA-39h7-pwv7-rc3x · Excalidraw vulnerable to XSS via Mermaid sequence diagram labels (KaTeX rendering)
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact `@excalidraw/[email protected]` depends on a Mermaid conversion package version that resolves to a Mermaid release affected by CVE-2025-54881 / GHSA-7rqq-prvp-x9jh. User-supplied Mermaid sequence diagram labels could trigger XSS through Mermaid’s KaTeX label rendering path. This is patched in `@excalidraw/[email protected]` by updating `@excalidraw/mermaid-to-excalidraw` to `2.2.2`, which uses a patched Mermaid 11 release. Moderate severity as this XSS requires manual user action - pasting unsafe Mermaid diagram into the Excalidraw editor. No semi-automated attack vector exists by default (such as accessing a link). ### Patches - Stable `@excalidraw/[email protected]` is patched. - Unstable `@excalidraw/excalidraw@next` has resolved to patched builds since `@excalidraw/[email protected]` on 2025-08-21. - Direct consumers of `@excalidraw/mermaid-to-excalidraw` should use `1.1.3` or later. ### Workarounds None. ### Resources - Upstream Mermaid advisory: https://github.com/mermaid-js/mermaid/security/advisories/GHSA-7rqq-prvp-x9jh - CVE-2025-54881
Fix available
- Published
- Updated
Stack: node
Affected products and versions
@excalidraw/excalidraw npm
- Versions
- 0.18.0
- Affected ranges
- SEMVER: ≥ 0.18.0, < 0.18.1
Update to 0.18.1
@excalidraw/mermaid-to-excalidraw npm
- Affected ranges
- SEMVER: ≥ 0.3.0, < 1.1.3
Update to 1.1.3
Original sources
- https://github.com/excalidraw/excalidraw/security/advisories/GHSA-39h7-pwv7-rc3x
- https://github.com/mermaid-js/mermaid/security/advisories/GHSA-7rqq-prvp-x9jh
- https://github.com/excalidraw/excalidraw
- https://github.com/excalidraw/excalidraw/releases/tag/v0.18.1
- https://osv.dev/vulnerability/GHSA-39h7-pwv7-rc3x