GHSA-39hc-v87j-747x
GHSA-39hc-v87j-747x · Vulnerable OpenSSL included in cryptography wheels
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 37.0.0-38.0.3 are vulnerable to a number of security issues. More details about the vulnerabilities themselves can be found in https://www.openssl.org/news/secadv/20221101.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
Fix available
- Published
- Updated
Stack: python
Affected products and versions
cryptography PyPI
- Versions
- 37.0.0
- 37.0.1
- 37.0.2
- 37.0.3
- 37.0.4
- 38.0.0
- 38.0.1
- 38.0.2
- Affected ranges
- ECOSYSTEM: ≥ 37.0.0, < 38.0.3
Update to 38.0.3
Original sources
- https://github.com/pyca/cryptography/security/advisories/GHSA-39hc-v87j-747x
- https://github.com/pyca/cryptography/commit/382e759bcded5773330eeed748c86b213ec618c5
- https://github.com/pyca/cryptography/commit/cf2ada625d1188d6cd46396f301b98095da577f7
- https://github.com/pyca/cryptography
- https://osv.dev/vulnerability/GHSA-39hc-v87j-747x