p PatchFirst

GHSA-39j2-4p9j-5w4j

GHSA-39j2-4p9j-5w4j · Ez Platform Object Injection in legacy shop module

This page contains facts from public vulnerability sources. Check the original advisory before updating.

This Security Advisory is about a vulnerability in the Legacy shop module. A backend editor could perform object injection in discount rules. This would require backend access and permission to edit discount rules. While object injection in itself is a serious vulnerability, the permission requirement means that normally only administrators would be able to exploit it, that's why it was classified as Medium severity.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • ezsystems/ezpublish-legacy Packagist

    Versions
    • v2019.03.0
    • v2019.03.1
    • v2019.03.2
    • v2019.03.3
    • v2019.03.4
    • v2019.03.4.2
    • v2019.03.5
    Affected ranges
    • ECOSYSTEM: ≥ 2019.3.0, < 2019.3.5.1

    Update to 2019.3.5.1

  • ezsystems/ezpublish-legacy Packagist

    Versions
    • v2017.12.0
    • v2017.12.1
    • v2017.12.1.1
    • v2017.12.2
    • v2017.12.2.1
    • v2017.12.2.2
    • v2017.12.3
    • v2017.12.3.1
    • v2017.12.3.2
    • v2017.12.4
    • v2017.12.4.1
    • v2017.12.4.2
    • v2017.12.4.3
    • v2017.12.5
    • v2017.12.6
    • v2017.12.7
    • v2017.12.7.2
    Affected ranges
    • ECOSYSTEM: ≥ 2017.12.0, < 2017.12.7.3

    Update to 2017.12.7.3

  • ezsystems/ezpublish-legacy Packagist

    Affected ranges
    • ECOSYSTEM: ≥ 5.4.0, < 5.4.14.2

    Update to 5.4.14.2

Original sources

Check your server →