p PatchFirst

GHSA-3fmq-x9q6-wm39

GHSA-3fmq-x9q6-wm39 · random_compat Uses insecure CSPRNG

This page contains facts from public vulnerability sources. Check the original advisory before updating.

random_compat versions prior to 2.0 are affected by a security vulnerability related to the insecure usage of Cryptographically Secure Pseudo-Random Number Generators (CSPRNG). The affected versions use openssl_random_pseudo_bytes(), which may result in insufficient entropy and compromise the security of generated random numbers.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • paragonie/random_compat Packagist

    Versions
    • 0.9.0
    • 0.9.1
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 1.0.10
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.0.6
    • 1.0.7
    • 1.0.8
    • 1.0.9
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.6
    • v0.9.7
    • v1.0.0
    • v1.0.1
    • v1.2.0
    • v1.2.1
    • v1.2.2
    • v1.2.3
    • v1.3.0
    • v1.3.1
    • v1.4.0
    • v1.4.1
    • v1.4.2
    • v1.4.3
    Affected ranges
    • ECOSYSTEM: < 2.0

    Update to 2.0

Original sources

Check your server →