p PatchFirst

GHSA-3vpc-4p9p-47hc

GHSA-3vpc-4p9p-47hc · curl_cffi bundles a version of libcurl affected by High Severity vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Summary curl_cffi is potentially affected by High Severity vulnerability (CVE-2023-38545) in libcurl<8.4.0 ### Details HIGH severity vulnerability in curl and libcurl: [announcement](https://github.com/curl/curl/discussions/12026#discussioncomment-7195548) Details are still unknown, but seems it will be a major issue as it's advertised by curl devs as "_probably the worst curl security flaw in a long time_". A patched version (8.4.0) and details will be published around 06:00 UTC on October 11. curl_cffi wheels on PyPI ship with libcurl 7.84.0 ### PoC [https://inspector.pypi.io/project/curl-cffi/0.5.10b2/packages/56/ae/eb7d39ad234f1f44650b910757d5aa696feff413d327c8328223ce78cb76/curl_cffi-0.5.10b2-cp37-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl/curl_cffi/include/curl/curlver.h](https://inspector.pypi.io/project/curl-cffi/0.5.10b2/packages/56/ae/eb7d39ad234f1f44650b910757d5aa696feff413d327c8328223ce78cb76/curl_cffi-0.5.10b2-cp37-abi3-manylinux_2_17_aarch64.manylinux2014_aarch64.whl/curl_cffi/include/curl/curlver.h) ### Resolution Versions after 0.7 bundles with `libcurl>=8.5`, which is not affected by this issue.

Fix available

Published
Updated

Stack: python

Affected products and versions

  • curl-cffi PyPI

    Versions
    • 0.1.5
    • 0.2.0
    • 0.2.1
    • 0.2.4
    • 0.2.5
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.7
    • 0.3.8
    • 0.4.0
    • 0.5.0
    • 0.5.1
    • 0.5.10
    • 0.5.10b1
    • 0.5.10b2
    • 0.5.10b3
    • 0.5.10b4
    • 0.5.10b5
    • 0.5.2
    • 0.5.3
    • 0.5.4
    • 0.5.5
    • 0.5.6
    • 0.5.7
    • 0.5.9
    • 0.5.9b1
    • 0.5.9b2
    • 0.5.9b3
    • 0.5.9b4
    • 0.5.9b5
    • 0.5.9b6
    • 0.6.0
    • 0.6.0b2
    • 0.6.0b4
    • 0.6.0b7
    • 0.6.0b9
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.6.3b1
    • 0.6.4
    • 0.7.0b4
    Affected ranges
    • ECOSYSTEM: < 0.7.0b6

    Update to 0.7.0b6

Original sources

Check your server →