p PatchFirst

GHSA-4459-qrcc-vfcf

GHSA-4459-qrcc-vfcf · TYPO3 Cross-Site Scripting in Form Framework

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Failing to properly encode user input, frontend forms handled by the form framework (system extension “form”) are vulnerable to cross-site scripting.

CVSS 6.1 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3/cms-core Packagist

    Versions
    • v8.7.10
    • v8.7.11
    • v8.7.12
    • v8.7.13
    • v8.7.14
    • v8.7.15
    • v8.7.16
    • v8.7.17
    • v8.7.18
    • v8.7.19
    • v8.7.20
    • v8.7.21
    • v8.7.22
    • v8.7.7
    • v8.7.8
    • v8.7.9
    Affected ranges
    • ECOSYSTEM: ≥ 8.5.0, < 8.7.23

    Update to 8.7.23

  • typo3/cms-core Packagist

    Versions
    • v9.0.0
    • v9.1.0
    • v9.2.0
    • v9.2.1
    • v9.3.0
    • v9.3.1
    • v9.3.2
    • v9.3.3
    • v9.4.0
    • v9.5.0
    • v9.5.1
    • v9.5.2
    • v9.5.3
    Affected ranges
    • ECOSYSTEM: ≥ 9.0.0, < 9.5.4

    Update to 9.5.4

Original sources

Check your server →