p PatchFirst

GHSA-4542-p56h-8xww

GHSA-4542-p56h-8xww · Cross-Site Scripting (XSS) vulnerabilities in Neos

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • typo3/neos Packagist

    Versions
    • 1.2.0
    • 1.2.1
    • 1.2.10
    • 1.2.11
    • 1.2.12
    • 1.2.2
    • 1.2.3
    • 1.2.4
    • 1.2.5
    • 1.2.6
    • 1.2.7
    • 1.2.8
    • 1.2.9
    Affected ranges
    • ECOSYSTEM: ≥ 1.2.0, < 1.2.13

    Update to 1.2.13

  • typo3/neos Packagist

    Versions
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    Affected ranges
    • ECOSYSTEM: ≥ 2.0.0, < 2.0.4

    Update to 2.0.4

Original sources

Check your server →