p PatchFirst

GHSA-4cv2-xc5f-px8h

GHSA-4cv2-xc5f-px8h · Denial of Service in extension "Code Highlight" (codehighlight)

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The codehighlight extension bundles a vulnerable version of the 3rd party JavaScript component “prism” which is known to be vulnerable against Regular expression Denial of Service (ReDoS).

CVSS 5.0 · Medium · Fix available

Published
Updated

Stack: php

Affected products and versions

  • brotkrueml/codehighlight Packagist

    Versions
    • v1.0.0
    • v1.0.1
    • v1.1.0
    • v1.1.1
    • v2.0.0
    • v2.0.1
    • v2.1.0
    • v2.2.0
    • v2.3.0
    • v2.4.0
    Affected ranges
    • ECOSYSTEM: < 2.5.0

    Update to 2.5.0

Original sources

Check your server →