GHSA-4qx8-j9vh-2628
GHSA-4qx8-j9vh-2628 · silverstripe/framework's User-Agent header not correctly invalidating user session
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A security protection device in Session designed to protect session hijacking was not correctly functioning. This function intended to protect user sessions by detecting changes in the User-Agent header, but modifications to this header were not correctly invalidating the user session.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/framework Packagist
- Versions
- 3.5.0
- 3.5.0-rc1
- 3.5.0-rc2
- 3.5.0-rc3
- 3.5.1
- 3.5.1-rc1
- 3.5.1-rc2
- 3.5.2
- 3.5.2-rc1
- 3.5.3
- 3.5.3-rc1
- 3.5.4
- 3.5.4-rc1
- 3.5.5
- 3.5.5-beta1
- 3.5.5-beta2
- 3.5.6-rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.5.0-rc1, < 3.5.6
Update to 3.5.6
silverstripe/framework Packagist
- Versions
- 3.6.0
- 3.6.0-rc1
- 3.6.1
- 3.6.1-alpha2
- 3.6.2
- 3.6.2-beta1
- 3.6.2-beta2
- 3.6.3-rc2
- Affected ranges
- ECOSYSTEM: ≥ 3.6.0-rc1, < 3.6.3
Update to 3.6.3
Original sources
- https://github.com/silverstripe/silverstripe-framework/commit/44de03da0147e6094b02602b7b73d5b1a1306d78
- https://github.com/silverstripe/silverstripe-framework/commit/d47667bb0768841e4b305fa95d5a4e2ba232c4ad
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2017-006-1.yaml
- https://github.com/silverstripe/silverstripe-framework
- https://www.silverstripe.org/download/security-releases/ss-2017-006
- https://osv.dev/vulnerability/GHSA-4qx8-j9vh-2628