GHSA-4rr6-gf59-ggw5
GHSA-4rr6-gf59-ggw5 · namshi/jose - Verification bypass
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Several widely-used JSON Web Token (JWT) libraries, including node-jsonwebtoken, pyjwt, namshi/jose, php-jwt, and jsjwt, are affected by critical vulnerabilities that could allow attackers to bypass the verification step when using asymmetric keys (RS256, RS384, RS512, ES256, ES384, ES512).
Fix available
- Published
- Updated
Stack: php
Affected products and versions
namshi/jose Packagist
- Versions
- 1.0.0
- 1.0.0-beta1
- 1.0.0-rc1
- 1.0.1
- 1.0.2
- 1.1.0
- 1.1.1
- 1.1.2
- 1.2.0
- 1.2.1
- 1.2.2
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- Affected ranges
- ECOSYSTEM: < 2.2.0
Update to 2.2.0
Original sources
- https://auth0.com/blog/2015/03/31/critical-vulnerabilities-in-json-web-token-libraries
- https://auth0.com/blog/critical-vulnerabilities-in-json-web-token-libraries
- https://github.com/FriendsOfPHP/security-advisories/blob/master/namshi/jose/2015-03-10.yaml
- https://github.com/namshi/jose
- https://osv.dev/vulnerability/GHSA-4rr6-gf59-ggw5