GHSA-537c-gmf6-5ccf
GHSA-537c-gmf6-5ccf · Vulnerable OpenSSL included in cryptography wheels
This page contains facts from public vulnerability sources. Check the original advisory before updating.
pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in wheels prior to cryptograph 48.01 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20260609.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.
CVSS 7.5 · High · Fix available
- Published
- Updated
Stack: python
Affected products and versions
cryptography PyPI
- Versions
- 0.5
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.4
- 0.6
- 0.6.1
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 1.0
- 1.0.1
- 1.0.2
- 1.1
- 1.1.1
- 1.1.2
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.4
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6
- 1.7
- 1.7.1
- 1.7.2
- 1.8
- 1.8.1
- 1.8.2
- 1.9
- 2.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.2
- 2.2.1
- 2.2.2
- 2.3
- 2.3.1
- 2.4
- 2.4.1
- 2.4.2
- 2.5
- 2.6
- 2.6.1
- 2.7
- 2.8
- 2.9
- 2.9.1
- 2.9.2
- 3.0
- 3.1
- 3.1.1
- 3.2
- 3.2.1
- 3.3
- 3.3.1
- 3.3.2
- 3.4
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.4.6
- 3.4.7
- 3.4.8
- 35.0.0
- 36.0.0
- 36.0.1
- 36.0.2
- 37.0.0
- 37.0.1
- 37.0.2
- 37.0.3
- 37.0.4
- 38.0.0
- 38.0.1
- 38.0.2
- 38.0.3
- 38.0.4
- 39.0.0
- 39.0.1
- 39.0.2
- 40.0.0
- 40.0.1
- 40.0.2
- 41.0.0
- 41.0.1
- 41.0.2
- 41.0.3
- 41.0.4
- 41.0.5
- 41.0.6
- 41.0.7
- 42.0.0
- 42.0.1
- 42.0.2
- 42.0.3
- 42.0.4
- 42.0.5
- 42.0.6
- 42.0.7
- 42.0.8
- 43.0.0
- 43.0.1
- 43.0.3
- 44.0.0
- 44.0.1
- 44.0.2
- 44.0.3
- 45.0.0
- 45.0.1
- 45.0.2
- 45.0.3
- 45.0.4
- 45.0.5
- 45.0.6
- 45.0.7
- 46.0.0
- 46.0.1
- 46.0.2
- 46.0.3
- 46.0.4
- 46.0.5
- 46.0.6
- 46.0.7
- 47.0.0
- 48.0.0
- Affected ranges
- ECOSYSTEM: ≥ 0.5.0, < 48.0.1
Update to 48.0.1