GHSA-5822-pw57-vv37
GHSA-5822-pw57-vv37 · XSS vulnerability when listing users on add & modify server pages.
This page contains facts from public vulnerability sources. Check the original advisory before updating.
### Impact An XSS vulnerability exists in versions of Pterodactyl Panel before 0.7.19. Affected versions do not properly sanitize account names before rendering them to the dropdown selector in the admin area when creating or modifying a server. ### Patches This XSS has been addressed in 0.7.19 and will be rolled forwards into the 1.0-rc.7 release. ### Workarounds No workaround exists without manual patching. See https://github.com/pterodactyl/panel/pull/2441/files for the files changed. ### For more information If you have any questions or comments about this advisory please reach out on Discord, or by emailing `dane` at `pterodactyl` dot `io`. _Thank you to Sergej for the responsible disclosure of this issue._
Fix available
- Published
- Updated
Stack: php
Affected products and versions
pterodactyl/panel Packagist
- Versions
- v0.1.0-beta
- v0.1.1-beta
- v0.1.2-beta
- v0.2.0-beta
- v0.3.0-beta
- v0.4.0-beta
- v0.4.1-beta
- v0.5.0
- v0.5.0-rc.1
- v0.5.0-rc.2
- v0.5.1
- v0.5.2
- v0.5.3
- v0.5.4
- v0.5.5
- v0.5.6
- v0.5.7
- v0.6.0
- v0.6.0-beta.1
- v0.6.0-beta.2
- v0.6.0-beta.2.1
- v0.6.0-rc.1
- v0.6.1
- v0.6.2
- v0.6.3
- v0.6.4
- v0.7.0
- v0.7.0-beta.1
- v0.7.0-beta.2
- v0.7.0-beta.3
- v0.7.0-beta.4
- v0.7.0-rc.1
- v0.7.0-rc.2
- v0.7.1
- v0.7.10
- v0.7.11
- v0.7.12
- v0.7.13
- v0.7.14
- v0.7.15
- v0.7.16
- v0.7.17
- v0.7.18
- v0.7.2
- v0.7.3
- v0.7.4
- v0.7.5
- v0.7.6
- v0.7.7
- v0.7.8
- v0.7.9
- Affected ranges
- ECOSYSTEM: < 0.7.19
Update to 0.7.19
pterodactyl/panel Packagist
- Versions
- v1.0.0-rc.1
- v1.0.0-rc.2
- v1.0.0-rc.3
- v1.0.0-rc.4
- v1.0.0-rc.5
- v1.0.0-rc.6
- Affected ranges
- ECOSYSTEM: ≥ 1.0.0-rc.0, < 1.0.0-rc.7
Update to 1.0.0-rc.7