p PatchFirst

GHSA-5j59-xgg2-r9c4

GHSA-5j59-xgg2-r9c4 · Next has a Denial of Service with Server Components - Incomplete Fix Follow-Up

This page contains facts from public vulnerability sources. Check the original advisory before updating.

It was discovered that the fix for [CVE-2025-55184](https://github.com/advisories/GHSA-2m3v-v2m8-q956) in React Server Components was incomplete and did not fully mitigate denial-of-service conditions across all payload types. As a result, certain crafted inputs could still trigger excessive resource consumption. This vulnerability affects React versions 19.0.2, 19.1.3, and 19.2.2, as well as frameworks that bundle or depend on these versions, including Next.js 13.x, 14.x, 15.x, and 16.x when using the App Router. The issue is tracked upstream as [CVE-2025-67779](https://www.cve.org/CVERecord?id=CVE-2025-67779). A malicious actor can send a specially crafted HTTP request to a Server Function endpoint that, when deserialized, causes the React Server Components runtime to enter an infinite loop. This can lead to sustained CPU consumption and cause the affected server process to become unresponsive, resulting in a denial-of-service condition in unpatched environments.

CVSS 7.5 · High · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next npm

    Affected ranges
    • SEMVER: ≥ 13.3.1-canary.0, < 14.2.35

    Update to 14.2.35

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.0.6, < 15.0.7

    Update to 15.0.7

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.1.10, < 15.1.11

    Update to 15.1.11

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.2.7, < 15.2.8

    Update to 15.2.8

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.3.7, < 15.3.8

    Update to 15.3.8

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.4.9, < 15.4.10

    Update to 15.4.10

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.5.8, < 15.5.9

    Update to 15.5.9

  • next npm

    Affected ranges
    • SEMVER: ≥ 15.6.0-canary.59, < 15.6.0-canary.60

    Update to 15.6.0-canary.60

  • next npm

    Affected ranges
    • SEMVER: ≥ 16.0.9, < 16.0.10

    Update to 16.0.10

  • next npm

    Affected ranges
    • SEMVER: ≥ 16.1.0-canary.17, < 16.1.0-canary.19

    Update to 16.1.0-canary.19

Original sources

Check your server →