GHSA-5qvp-pr9f-2g2v
GHSA-5qvp-pr9f-2g2v · poetry-plugin-tweak-dependencies-version affected by CVE-2026-25645
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Pin vulnerable version of requests library
CVSS 4.4 · Medium · Fix available
- Published
- Updated
Stack: python
Affected products and versions
poetry-plugin-tweak-dependencies-version PyPI
- Versions
- 0.1.0
- 0.1.6
- 0.1.7
- 0.2.0
- 0.2.1
- 1.0.0
- 1.1.0
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.4
- 1.5.5
- Affected ranges
- ECOSYSTEM: < 1.5.6
Update to 1.5.6
Original sources
- https://github.com/psf/requests/security/advisories/GHSA-gc5v-m9x4-r6x2
- https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/security/advisories/GHSA-5qvp-pr9f-2g2v
- https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/commit/54b5784d89f36cd413a8bc5032ab0a96438dcae3
- https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version
- https://github.com/sbrunner/poetry-plugin-tweak-dependencies-version/releases/tag/1.5.6
- https://osv.dev/vulnerability/GHSA-5qvp-pr9f-2g2v