p PatchFirst

GHSA-67cx-rhhq-mfhq

GHSA-67cx-rhhq-mfhq · High severity vulnerability that affects indico

This page contains facts from public vulnerability sources. Check the original advisory before updating.

## Local file disclosure through LaTeX injection ### Impact An external audit of the Indico codebase has discovered a vulnerability in Indico's LaTeX sanitization code, which could have malicious users to run unsafe LaTeX commands on the server. Such commands allowed for example to read local files (e.g. `indico.conf`). As far as we know it is not possible to write files or execute code using this vulnerability. ### Patches You need to update to [Indico 2.2.3](https://github.com/indico/indico/releases/tag/v2.2.3) as soon as possible. We also released [Indico 2.1.10](https://github.com/indico/indico/releases/tag/v2.1.10) in case you cannot update to 2.2 for some reason. See https://docs.getindico.io/en/stable/installation/upgrade/ for instructions on how to update. ### Workarounds Setting `XELATEX_PATH = None` in `indico.conf` will result in an error when building a PDF, but without being able to run xelatex, the vulnerability cannot be abused. ### For more information If you have any questions or comments about this advisory: * Open a thread in [our forum](https://talk.getindico.io/) * Email us privately at [[email protected]](mailto:[email protected])

Fix available

Published
Updated

Stack: python

Affected products and versions

  • indico PyPI

    Versions
    • 0.98-rc1
    • 0.98.0
    • 0.98.1
    • 0.98.2
    • 0.99
    • 1.0
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.2
    • 1.2.1
    • 1.2.1rc10
    • 1.2.1rc11
    • 1.2.1rc2
    • 1.2.1rc4
    • 1.2.1rc5
    • 1.2.1rc6
    • 1.2.1rc7
    • 1.2.1rc9
    • 1.2.2
    • 1.2.2rc1
    • 1.9.11.dev10
    • 1.9.11.dev11
    • 1.9.11.dev12
    • 1.9.11.dev13
    • 1.9.11.dev14
    • 1.9.11.dev15
    • 1.9.11.dev16
    • 1.9.11.dev17
    • 1.9.11.dev3
    • 1.9.11.dev4
    • 1.9.11.dev6
    • 1.9.11.dev7
    • 1.9.11.dev8
    • 1.9.11.dev9
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0a1
    • 2.0rc1
    • 2.0rc2
    • 2.1
    • 2.1.1
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    Affected ranges
    • ECOSYSTEM: < 2.1.10

    Update to 2.1.10

  • indico PyPI

    Versions
    • 2.2
    • 2.2.1
    • 2.2.2
    Affected ranges
    • ECOSYSTEM: ≥ 2.2.0, < 2.2.3

    Update to 2.2.3

Original sources

Check your server →