GHSA-6hh6-59j2-qrxw
GHSA-6hh6-59j2-qrxw · Silverstripe History XSS Vulnerability
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A cross-site scripting vulnerability has been discovered in the CMS page history tab. This vulnerability can only be exploited if a user with CMS access has posted malicious or unescaped HTML into any of the text fields on a page, and if the "compare mode" option is selected. The HTML will be embedded into the page unescaped. This has been resolved by performing the text comparison in a HTML friendly way.
CVSS 6.1 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/cms Packagist
- Versions
- 3.1.0
- 3.1.1
- 3.1.10-rc1
- 3.1.10-rc2
- 3.1.2
- 3.1.2-rc1
- 3.1.3
- 3.1.3-rc1
- 3.1.3-rc2
- 3.1.4
- 3.1.4-rc1
- 3.1.5
- 3.1.5-rc1
- 3.1.6
- 3.1.6-rc1
- 3.1.6-rc2
- 3.1.6-rc3
- 3.1.7
- 3.1.7-rc1
- 3.1.8
- 3.1.9
- 3.1.9-rc1
- Affected ranges
- ECOSYSTEM: ≥ 3.1.0, < 3.1.10
Update to 3.1.10