GHSA-6v6p-g8cg-2hgg
GHSA-6v6p-g8cg-2hgg · Improper Certificate Validation in node-sass affects eZ Platform
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Certificate validation in node-sass 2.0.0 to 4.14.1 is disabled when requesting binaries even if the user is not specifying an alternative download path. This affects eZ Platform v2.5 only. The maintainers resolved it by replacing node-sass 4.11 with sass 1.32.13. This issue also affects ezsystems/ezplatform and ezsystems/ezplatform-page-builder.
CVSS 5.3 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
ezsystems/ezplatform-admin-ui Packagist
- Versions
- v1.5.0
- v1.5.1
- v1.5.10
- v1.5.11
- v1.5.12
- v1.5.13
- v1.5.14
- v1.5.15
- v1.5.16
- v1.5.17
- v1.5.18
- v1.5.19
- v1.5.2
- v1.5.20
- v1.5.21
- v1.5.22
- v1.5.23
- v1.5.24
- v1.5.25
- v1.5.25.1
- v1.5.26
- v1.5.3
- v1.5.4
- v1.5.5
- v1.5.6
- v1.5.7
- v1.5.8
- v1.5.8-rc1
- v1.5.9
- v1.5.9-rc1
- Affected ranges
- ECOSYSTEM: ≥ 1.5.0, < 1.5.27
Update to 1.5.27
Original sources
- https://github.com/ezsystems/ezplatform-admin-ui/security/advisories/GHSA-6v6p-g8cg-2hgg
- https://nvd.nist.gov/vuln/detail/CVE-2020-24025
- https://developers.ibexa.co/security-advisories/ibexa-sa-2022-002-vulnerability-in-node-sass
- https://github.com/advisories/GHSA-r8f7-9pfq-mjmv
- https://github.com/ezsystems/ezplatform-admin-ui
- https://github.com/ezsystems/ezplatform-admin-ui/releases/tag/v1.5.27
- https://osv.dev/vulnerability/GHSA-6v6p-g8cg-2hgg