GHSA-7644-cxp8-h23r
GHSA-7644-cxp8-h23r · ibexa/admin-ui vulnerable to Cross-site Scripting in content type name/shortname
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Critical severity. It is possible to inject JavaScript XSS in the content type entries "name" and "short name". To exploit this, one must already have permission to edit content types, which limits it in many cases to people who are already administrators. However, please verify which users have this permission. The fix ensures any injections are escaped.
Fix available
- Published
- Updated
Stack: php
Affected products and versions
ibexa/admin-ui Packagist
- Versions
- v4.2.0
- v4.2.1
- v4.2.2
- Affected ranges
- ECOSYSTEM: ≥ 4.2.0, < 4.2.3
Update to 4.2.3
Original sources
- https://github.com/ibexa/admin-ui/security/advisories/GHSA-7644-cxp8-h23r
- https://developers.ibexa.co/security-advisories/ibexa-sa-2022-009-critical-vulnerabilities-in-graphql-role-assignment-ct-editing-and-drafts-tooltips
- https://github.com/ibexa/admin-ui
- https://osv.dev/vulnerability/GHSA-7644-cxp8-h23r