p PatchFirst

GHSA-78hm-5hjw-58mh

GHSA-78hm-5hjw-58mh · ua-parser/uap-php ReDoS vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

A regex expression in ua-parser/uap-php could lead to a ReDoS vulnerability in versions prior to 3.8.0.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • ua-parser/uap-php Packagist

    Versions
    • v3.4.0
    • v3.4.1
    • v3.4.2
    • v3.4.3
    • v3.4.4
    • v3.4.5
    • v3.4.6
    • v3.4.7
    • v3.5.0
    • v3.6.0
    • v3.7.0
    Affected ranges
    • ECOSYSTEM: < 3.8.0

    Update to 3.8.0

Original sources

Check your server →