GHSA-7q33-hxwj-7p8v
GHSA-7q33-hxwj-7p8v · TYPO3 Cross-Site Scripting in Backend Modal Component
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Failing to properly encode user input, notifications shown in modal windows in the TYPO3 backend are vulnerable to cross-site scripting. A valid backend user account is needed in order to exploit this vulnerability.
CVSS 5.4 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
typo3/cms Packagist
- Versions
- 7.0.0
- 7.0.1
- 7.0.2
- 7.1.0
- 7.2.0
- 7.3.0
- 7.3.1
- 7.4.0
- 7.5.0
- 7.6.0
- 7.6.1
- 7.6.10
- 7.6.11
- 7.6.12
- 7.6.13
- 7.6.14
- 7.6.15
- 7.6.16
- 7.6.17
- 7.6.18
- 7.6.19
- 7.6.2
- 7.6.3
- 7.6.4
- 7.6.5
- 7.6.6
- 7.6.7
- 7.6.8
- 7.6.9
- v7.6.20
- v7.6.21
- v7.6.22
- v7.6.23
- v7.6.24
- v7.6.25
- v7.6.26
- v7.6.27
- v7.6.28
- v7.6.29
- v7.6.30
- v7.6.31
- Affected ranges
- ECOSYSTEM: ≥ 7.0.0, < 7.6.32
Update to 7.6.32
typo3/cms Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.2.1
- 8.3.0
- 8.3.1
- 8.4.0
- 8.4.1
- 8.5.0
- 8.5.1
- 8.6.0
- 8.6.1
- 8.7.0
- 8.7.1
- 8.7.2
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.3
- v8.7.4
- v8.7.5
- v8.7.6
- v8.7.7
- v8.7.8
- v8.7.9
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.7.21
Update to 8.7.21
typo3/cms Packagist
- Versions
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- Affected ranges
- ECOSYSTEM: ≥ 9.0.0, < 9.5.2
Update to 9.5.2
Original sources
- https://github.com/TYPO3/typo3/commit/02cd5c97228cba477d16c68e28309ce25c433ce9
- https://github.com/TYPO3/typo3/commit/89a38ad0ef9411745954f53f29bea5b8ce81cd32
- https://github.com/TYPO3/typo3/commit/c35646c3f7795a4a7b0046a88f146b490fa4883c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/2018-12-11-2.yaml
- https://github.com/TYPO3/typo3
- https://typo3.org/security/advisory/typo3-core-sa-2018-007
- https://osv.dev/vulnerability/GHSA-7q33-hxwj-7p8v