p PatchFirst

GHSA-7v28-g2pq-ggg8

GHSA-7v28-g2pq-ggg8 · Ghost vulnerable to remote code execution in locale setting change

This page contains facts from public vulnerability sources. Check the original advisory before updating.

### Impact A [vulnerability](https://www.cve.org/CVERecord?id=CVE-2022-24785) in an upstream library means an authenticated attacker can abuse locale input to execute arbitrary commands from a file that has previously been uploaded using the file upload functionality in the post editor. ### Patches Fixed in 5.2.3, all 5.x sites should update as soon as possible. Fixed in 4.48.2, all 4.x sites should update as soon as possible. ### Workarounds Patched versions of Ghost add validation to the locale input to prevent execution of arbitrary files. Updating Ghost is the quickest complete solution. As a workaround, if for any reason you cannot update your Ghost instance, you can block the `POST /ghost/api/admin/settings/` endpoint, which will also disable updating settings for your site. ### For more information If you have any questions or comments about this advisory: * Email us at [[email protected]](mailto:[email protected]) ### Credits * devx00 - https://twitter.com/devx00

CVSS 6.6 · Medium · Fix available

Published
Updated

Stack: node

Affected products and versions

  • ghost npm

    Affected ranges
    • SEMVER: < 4.48.2

    Update to 4.48.2

  • ghost npm

    Affected ranges
    • SEMVER: ≥ 5.0.0, < 5.2.3

    Update to 5.2.3

Original sources

Check your server →