p PatchFirst

GHSA-98j6-67v3-mw34

GHSA-98j6-67v3-mw34 · Auth0 Symfony SDK Deserialization of Untrusted Data vulnerability

This page contains facts from public vulnerability sources. Check the original advisory before updating.

**Overview** The Auth0 Symfony SDK contains a critical vulnerability due to insecure deserialization of cookie data. If exploited, since SDKs process cookie content without prior authentication, a threat actor could send a specially crafted cookie containing malicious serialized data. **Am I Affected?** You are affected by this vulnerability if you meet the following preconditions: 1. Applications using the Auth0 Symfony SDK, versions between 5.0.0 BETA-0 to 5.0.0. 2. Auth0 Symfony SDK uses the Auth0-PHP SDK with version 8.0.0-BETA3 to 8.3.0. **Fix** Upgrade Auth0/symfony to the latest version (v5.4.0). **Acknowledgement** Okta would like to thank Andreas Forsblom for discovering this vulnerability.

CVSS 9.3 · Critical · Fix available

Published
Updated

Stack: php

Affected products and versions

  • auth0/symfony Packagist

    Versions
    • 5.0.0
    • 5.0.0-BETA0
    • 5.0.0-BETA1
    Affected ranges
    • ECOSYSTEM: ≥ 5.0.0-BETA0, < 5.1.0

    Update to 5.1.0

Original sources

Check your server →