p PatchFirst

GHSA-c4c3-j73v-634r

GHSA-c4c3-j73v-634r · silverstripe/framework has Cross-site Scripting vulnerability in page history comparison

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Authenticated user with page edit permission can craft HTML, which when rendered in a page history comparison can execute client scripts.

Fix available

Published
Updated

Stack: php

Affected products and versions

  • silverstripe/framework Packagist

    Versions
    • 3.4.0
    • 3.4.0-rc1
    • 3.4.1
    • 3.4.1-rc1
    • 3.4.1-rc2
    • 3.4.2
    • 3.4.3
    • 3.4.3-rc1
    • 3.4.4
    • 3.4.4-rc1
    • 3.4.5
    • 3.4.5-rc1
    • 3.4.6-rc1
    • 3.4.6-rc2
    Affected ranges
    • ECOSYSTEM: ≥ 3.4.0-rc1, < 3.4.6

    Update to 3.4.6

  • silverstripe/framework Packagist

    Versions
    • 3.5.0
    • 3.5.0-rc1
    • 3.5.0-rc2
    • 3.5.0-rc3
    • 3.5.1
    • 3.5.1-rc1
    • 3.5.1-rc2
    • 3.5.2
    • 3.5.2-rc1
    • 3.5.3
    • 3.5.3-rc1
    • 3.5.4-rc1
    Affected ranges
    • ECOSYSTEM: ≥ 3.5.0-rc1, < 3.5.4

    Update to 3.5.4

Original sources

Check your server →