GHSA-cc2j-92jq-wgjg
GHSA-cc2j-92jq-wgjg · eZ Publish Information disclosure in backend content tree menu
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This security advisory fixes an information disclosure vulnerability in the legacy admin content tree menu. If a view has been disabled in site.ini [SiteAccessRules] Rules, and an attacker accesses the backend with the URL to this module, then the tree menu may be displayed. Since the tree menu may contain hidden items, this may lead to information disclosure. We recommend that you install this Security Update as soon as possible. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/a4a0470f8d80f012fe14e4f8ab11c7d14375986c
Fix available
- Published
- Updated
Stack: php
Affected products and versions
ezsystems/ezpublish-legacy Packagist
- Versions
- 2013.04.0
- v2013.05.0
- v2013.06.0
- v2013.07.0
- v2013.07.1
- v2013.07.3
- v2013.09.0
- v2013.11
- v2014.01.0
- v2014.01.1
- v2014.01.2
- v2014.03.1
- v2014.03.2
- v2014.05.0
- v2014.05.1
- v2014.05.2
- v2014.07.0
- v2014.07.1
- v2014.07.2
- v2014.11.0
- v2014.11.1
- v2014.11.2
- v2015.01.0
- v2015.01.1
- v2015.01.2
- v2015.01.3
- v2017.08.0
- v2017.08.1
- Affected ranges
- ECOSYSTEM: ≥ 2011.0.0, < 2017.8.1.1
Update to 2017.8.1.1
ezsystems/ezpublish-legacy Packagist
- Affected ranges
- ECOSYSTEM: ≥ 5.4.0, < 5.4.10.1
Update to 5.4.10.1
ezsystems/ezpublish-legacy Packagist
- Affected ranges
- ECOSYSTEM: ≥ 5.3.0, < 5.3.12.2
Update to 5.3.12.2
Original sources
- https://github.com/ezsystems/ezpublish-legacy/commit/a4a0470f8d80f012fe14e4f8ab11c7d14375986c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/ezsystems/ezpublish-legacy/2017-09-11-1.yaml
- https://github.com/ezsystems/ezpublish-legacy
- http://share.ez.no/community-project/security-advisories/ezsa-2017-006-information-disclosure-in-backend-content-tree-menu
- https://osv.dev/vulnerability/GHSA-cc2j-92jq-wgjg