GHSA-f777-f784-36gm
GHSA-f777-f784-36gm · TYPO3 Security Misconfiguration in Install Tool Cookie
This page contains facts from public vulnerability sources. Check the original advisory before updating.
It has been discovered that cookies created in the Install Tool are not hardened to be submitted only via HTTP. In combination with other vulnerabilities such as cross-site scripting it can lead to hijacking an active and valid session in the Install Tool.
CVSS 8.1 · High · Fix available
- Published
- Updated
Stack: php
Affected products and versions
typo3/cms Packagist
- Versions
- 7.0.0
- 7.0.1
- 7.0.2
- 7.1.0
- 7.2.0
- 7.3.0
- 7.3.1
- 7.4.0
- 7.5.0
- 7.6.0
- 7.6.1
- 7.6.10
- 7.6.11
- 7.6.12
- 7.6.13
- 7.6.14
- 7.6.15
- 7.6.16
- 7.6.17
- 7.6.18
- 7.6.19
- 7.6.2
- 7.6.3
- 7.6.4
- 7.6.5
- 7.6.6
- 7.6.7
- 7.6.8
- 7.6.9
- v7.6.20
- v7.6.21
- v7.6.22
- v7.6.23
- v7.6.24
- v7.6.25
- v7.6.26
- v7.6.27
- v7.6.28
- v7.6.29
- v7.6.30
- v7.6.31
- Affected ranges
- ECOSYSTEM: ≥ 7.0.0, < 7.6.32
Update to 7.6.32
typo3/cms Packagist
- Versions
- 8.0.0
- 8.0.1
- 8.1.0
- 8.1.1
- 8.1.2
- 8.2.0
- 8.2.1
- 8.3.0
- 8.3.1
- 8.4.0
- 8.4.1
- 8.5.0
- 8.5.1
- 8.6.0
- 8.6.1
- 8.7.0
- 8.7.1
- 8.7.2
- v8.7.10
- v8.7.11
- v8.7.12
- v8.7.13
- v8.7.14
- v8.7.15
- v8.7.16
- v8.7.17
- v8.7.18
- v8.7.19
- v8.7.20
- v8.7.3
- v8.7.4
- v8.7.5
- v8.7.6
- v8.7.7
- v8.7.8
- v8.7.9
- Affected ranges
- ECOSYSTEM: ≥ 8.0.0, < 8.7.21
Update to 8.7.21
typo3/cms Packagist
- Versions
- v9.0.0
- v9.1.0
- v9.2.0
- v9.2.1
- v9.3.0
- v9.3.1
- v9.3.2
- v9.3.3
- v9.4.0
- v9.5.0
- v9.5.1
- Affected ranges
- ECOSYSTEM: ≥ 9.0.0, < 9.5.2
Update to 9.5.2
Original sources
- https://github.com/TYPO3/typo3/commit/13328b0f74ac589a20b021db814dfa672581c26a
- https://github.com/TYPO3/typo3/commit/918e50e4d20d88c7e40ad3bb134267d07706b0b1
- https://github.com/TYPO3/typo3/commit/a5359491e3fb3164a6ba96a66c8e67fbb9971a4c
- https://github.com/FriendsOfPHP/security-advisories/blob/master/typo3/cms/2018-12-11-4.yaml
- https://github.com/TYPO3/typo3
- https://typo3.org/security/advisory/typo3-core-sa-2018-009
- https://osv.dev/vulnerability/GHSA-f777-f784-36gm