GHSA-frm9-7pm9-5rgc
GHSA-frm9-7pm9-5rgc · SilverStripe comments module includes version of jQuery vulnerable to Cross-site Scripting
This page contains facts from public vulnerability sources. Check the original advisory before updating.
The silverstripe/comments module, the cwp/starter-theme and the cwp/watea-theme include an outdated version of jQuery by default, which contains XSS vulnerabilities if user input is used in certain contexts. Though no known exploit has been found for these in the existing usage, user customisation to these themes could have made them exploitable. CWP 2.0.0 has been released with the fixed cwp/stater-theme and silverstripe/comments module, and SilverStripe 4.2.0 will be released with the fixed silverstripe-themes/simple theme.
CVSS 4.4 · Medium · Fix available
- Published
- Updated
Stack: php
Affected products and versions
silverstripe/comments Packagist
- Versions
- 2.0.0
- 2.0.0-beta1
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- 2.1.7
- 3.0.0
- 3.0.0-beta1
- 3.0.0-beta2
- 3.1.0
- Affected ranges
- ECOSYSTEM: ≥ 1.3.0, < 3.1.1
Update to 3.1.1